Project

General

Profile

Bug #14306

"RadosModel.h: 854: FAILED assert(0)" in rados-hammer-distro-basic-openstack

Added by Yuri Weinstein about 7 years ago. Updated almost 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rados
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Could be related to #14236

Run: http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2016-01-07_21:00:01-rados-hammer-distro-basic-openstack/
Job: 62653
Logs: http://teuthology.ovh.sepia.ceph.com/teuthology/teuthology-2016-01-07_21:00:01-rados-hammer-distro-basic-openstack/62653/teuthology.log

2016-01-08T00:33:07.905 INFO:tasks.rados.rados.0.target087097.stdout:7254:  finishing write tid 1 to target087097.ovh.sepia.ceph.com11949-7254
2016-01-08T00:33:07.906 INFO:tasks.rados.rados.0.target087097.stderr:Error: finished tid 1 when last_acked_tid was 6
2016-01-08T00:33:07.945 INFO:tasks.rados.rados.0.target087097.stderr:./test/osd/RadosModel.h: In function 'virtual void WriteOp::_finish(TestOp::CallbackInfo*)' thread 7f4271ffb700 time 2016-01-08 00:33:07.779044
2016-01-08T00:33:07.945 INFO:tasks.rados.rados.0.target087097.stderr:./test/osd/RadosModel.h: 854: FAILED assert(0)
2016-01-08T00:33:07.947 INFO:tasks.rados.rados.0.target087097.stderr: ceph version 0.94.5-178-g9739d4d (9739d4de49f8167866eda556b2f1581c068ec8a7)
2016-01-08T00:33:07.948 INFO:tasks.rados.rados.0.target087097.stderr: 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x8b) [0x4e05fb]
2016-01-08T00:33:07.953 INFO:tasks.rados.rados.0.target087097.stderr: 2: (WriteOp::_finish(TestOp::CallbackInfo*)+0x46e) [0x4c83ae]
2016-01-08T00:33:07.953 INFO:tasks.rados.rados.0.target087097.stderr: 3: (write_callback(void*, void*)+0x19) [0x4d7bf9]
2016-01-08T00:33:07.954 INFO:tasks.rados.rados.0.target087097.stderr: 4: (()+0xb4b7d) [0x7f427fdbbb7d]
2016-01-08T00:33:07.955 INFO:tasks.rados.rados.0.target087097.stderr: 5: (()+0x900c9) [0x7f427fd970c9]
2016-01-08T00:33:07.956 INFO:tasks.rados.rados.0.target087097.stderr: 6: (()+0x1544c8) [0x7f427fe5b4c8]
2016-01-08T00:33:07.956 INFO:tasks.rados.rados.0.target087097.stderr: 7: (()+0x8182) [0x7f427f8db182]
2016-01-08T00:33:07.956 INFO:tasks.rados.rados.0.target087097.stderr: 8: (clone()+0x6d) [0x7f427e26047d]
2016-01-08T00:33:07.957 INFO:tasks.rados.rados.0.target087097.stderr: NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.


Related issues

Duplicates Ceph - Bug #12814: flipping the overlay from forward to seems to reorder writes Can't reproduce 08/27/2015

History

#1 Updated by Yuri Weinstein about 7 years ago

  • Description updated (diff)

#2 Updated by Yuri Weinstein about 7 years ago

  • Project changed from rbd to Ceph

#3 Updated by Yuri Weinstein about 7 years ago

  • Related to Backport #14236: "OSDMonitor.cc: 2116: FAILED assert(0)" in rados-hammer-distro-basic-openstack added

#4 Updated by Samuel Just about 7 years ago

  • Related to deleted (Backport #14236: "OSDMonitor.cc: 2116: FAILED assert(0)" in rados-hammer-distro-basic-openstack)

#5 Updated by Samuel Just about 7 years ago

  • Duplicates Bug #12814: flipping the overlay from forward to seems to reorder writes added

#6 Updated by Samuel Just about 7 years ago

  • Status changed from New to Duplicate

#7 Updated by Yuri Weinstein almost 7 years ago

Run: http://pulpito.ceph.com/teuthology-2016-02-01_09:00:02-rados-hammer-distro-basic-vps/
Job: ['43']

WriteOp::_finish(TestOp::CallbackInfo*)' thread 7f873e1c0700 time 2016-02-01 20:31:50.240676
2016-02-01T12:31:50.778 INFO:tasks.rados.rados.0.vpm072.stderr:./test/osd/RadosModel.h: 854: FAILED assert(0)
2016-02-01T12:31:50.778 INFO:tasks.rados.rados.0.vpm072.stderr: ceph version 0.94.5-290-g2c8e579 (2c8e57934284dae0ae92d1aa0839a87092ec7c51)
2016-02-01T12:31:50.779 INFO:tasks.rados.rados.0.vpm072.stderr: 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x8b) [0x4e05fb]
2016-02-01T12:31:50.779 INFO:tasks.rados.rados.0.vpm072.stderr: 2: (WriteOp::_finish(TestOp::CallbackInfo*)+0x46e) [0x4c83ae]
2016-02-01T12:31:50.779 INFO:tasks.rados.rados.0.vpm072.stderr: 3: (write_callback(void*, void*)+0x19) [0x4d7bf9]
2016-02-01T12:31:50.779 INFO:tasks.rados.rados.0.vpm072.stderr: 4: (()+0x94ced) [0x7f87464ffced]
2016-02-01T12:31:50.780 INFO:tasks.rados.rados.0.vpm072.stderr: 5: (()+0x70019) [0x7f87464db019]
2016-02-01T12:31:50.780 INFO:tasks.rados.rados.0.vpm072.stderr: 6: (()+0x134638) [0x7f874659f638]
2016-02-01T12:31:50.780 INFO:tasks.rados.rados.0.vpm072.stderr: 7: (()+0x8182) [0x7f874603f182]
2016-02-01T12:31:50.780 INFO:tasks.rados.rados.0.vpm072.stderr: 8: (clone()+0x6d) [0x7f87449c447d]
2016-02-01T12:31:50.781 INFO:tasks.rados.rados.0.vpm072.stderr: NOTE: a copy of the executable, or `objdump -rdS <executable>` is needed to interpret this.

Also available in: Atom PDF