Project

General

Profile

Bug #14121

"[ FAILED ] TestLibRBD.RebuildObjectMap" in upgrade:client-upgrade-jewel-distro-basic-openstack

Added by Yuri Weinstein almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Jason Dillaman
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
upgrade/client-upgrade
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Run: http://pulpito.ovh.sepia.ceph.com:8081/teuthology-2015-12-16_23:20:01-upgrade:client-upgrade-jewel-distro-basic-openstack/
Job: 41629
Logs: http://teuthology.ovh.sepia.ceph.com/teuthology/teuthology-2015-12-16_23:20:01-upgrade:client-upgrade-jewel-distro-basic-openstack/41629/teuthology.log

2015-12-18T01:34:22.904 INFO:tasks.workunit.client.0.target072097.stdout:using new format!
2015-12-18T01:34:23.537 INFO:tasks.workunit.client.0.target072097.stdout:test/librbd/test_librbd.cc:3064: Failure
2015-12-18T01:34:23.538 INFO:tasks.workunit.client.0.target072097.stdout:Value of: (flags & RBD_FLAG_OBJECT_MAP_INVALID) != 0
2015-12-18T01:34:23.538 INFO:tasks.workunit.client.0.target072097.stdout:  Actual: false
2015-12-18T01:34:23.538 INFO:tasks.workunit.client.0.target072097.stdout:Expected: true
2015-12-18T01:34:23.549 INFO:tasks.workunit.client.0.target072097.stdout:[  FAILED  ] TestLibRBD.RebuildObjectMap (645 ms)

Associated revisions

Revision 7676343c (diff)
Added by Jason Dillaman almost 6 years ago

tests: rebuild exclusive lock test should acquire exclusive lock

Starting with Jewel, the object map will not be loaded until the
exclusive lock is acquired since it might be updated by the
lock owner.

Fixes: #14121
Signed-off-by: Jason Dillaman <>

History

#1 Updated by Josh Durgin almost 6 years ago

  • Project changed from Ceph to rbd

#2 Updated by Jason Dillaman almost 6 years ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman

#3 Updated by Jason Dillaman almost 6 years ago

  • Status changed from In Progress to Fix Under Review

#4 Updated by Jason Dillaman almost 6 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF