Project

General

Profile

Feature #1412

qa: spec out messenger testing

Added by Sage Weil almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
qa
Target version:
% Done:

0%

Source:
Tags:
Backport:
Reviewed:
Affected Versions:
Pull request ID:

Description

use Colin's multiprocess framework to do a messenger test for reconnects, with socket failure injects.

types:
- client->server (lossy, e.g. client/osd, client/mon)
- client->server (lossless, e.g. client/mds)
- server/server (mds, osd, mon intracluster)
- racing connections. someting like barrier, send messages to each other, make sure they both arrive, barrier, mark down, repeat.

- inject socket errors, verify all messages go through (all types)


Related issues

Related to Ceph - Bug #1631: osd: failed assert(repop_queue.front() == repop) Can't reproduce 10/18/2011

History

#1 Updated by Sage Weil almost 9 years ago

  • Target version changed from v0.35 to v0.36
  • translation missing: en.field_position set to 2

#2 Updated by Sage Weil almost 9 years ago

  • translation missing: en.field_position deleted (30)
  • translation missing: en.field_position set to 65

#3 Updated by Sage Weil almost 9 years ago

  • translation missing: en.field_story_points set to 5
  • translation missing: en.field_position deleted (74)
  • translation missing: en.field_position set to 74

#4 Updated by Sage Weil almost 9 years ago

  • Target version deleted (v0.36)
  • translation missing: en.field_position deleted (81)
  • translation missing: en.field_position set to 1

#5 Updated by Sage Weil over 8 years ago

  • translation missing: en.field_position deleted (12)
  • translation missing: en.field_position set to 24

#6 Updated by Sage Weil over 8 years ago

  • translation missing: en.field_position deleted (77)
  • translation missing: en.field_position set to 66

#7 Updated by Sage Weil over 8 years ago

  • translation missing: en.field_position deleted (134)
  • translation missing: en.field_position set to 1

#8 Updated by Sage Weil over 8 years ago

  • Target version set to v0.43
  • translation missing: en.field_position deleted (4)
  • translation missing: en.field_position set to 28

#9 Updated by Sage Weil over 8 years ago

  • Status changed from New to Can't reproduce

this code has been refactored a bit.

the messenger tests won't directly trigger this, though we may the/an underlying msgr bug that may have caused it. i don't think there's value in keeping this open.

#10 Updated by Sage Weil over 8 years ago

er, wrong bug!

#11 Updated by Sage Weil over 8 years ago

  • Tracker changed from Feature to Bug

#12 Updated by Sage Weil over 8 years ago

  • Status changed from Can't reproduce to New

#13 Updated by Sage Weil over 8 years ago

  • Tracker changed from Bug to Feature

#14 Updated by Sage Weil over 8 years ago

  • Subject changed from qa: messenger connect/reconnect tester to qa: spec out messenger testing
  • Status changed from New to Resolved

we now have a high-level plan on how to attack msgr testing.

Also available in: Atom PDF