Project

General

Profile

Bug #14074

OSD daemon can not start after cluster deployment

Added by bo cai almost 4 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
12/14/2015
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

I cloned the latest code and compile packaged into deb, then to the respective host DEB install a new package, version 10.0.1.
Next, I use ceph-deploy (1.5.28) to deploy the cluster, in the increase OSD, without any errors.
But ceph osd tree does not show any osd information.
We use the following command:
ceph-deploy new node1
ceph-deploy mon --overwrite-conf create-initial
ceph-deploy --overwrite-conf gatherkeys node1
  1. Then I copy ceph config file to node2
    ceph-deploy --overwrite-conf osd create node2: / dev / sdb

I also tried a manual deployment, osd successful deployment, but can not start osd process.
I checked the log information is as follows:

2015-12-14 01:49:53.783910 7f03883cd7c0 1 filestore(/var/lib/ceph/osd/ceph-0) mkfs done in /var/lib/ceph/osd/ceph-0
2015-12-14 01:49:53.797667 7f03883cd7c0 0 filestore(/var/lib/ceph/osd/ceph-0) backend xfs (magic 0x58465342)
2015-12-14 01:49:53.798726 7f03883cd7c0 0 genericfilestorebackend(/var/lib/ceph/osd/ceph-0) detect_features: FIEMAP ioctl is disabled via 'filestore fiemap' config option
2015-12-14 01:49:53.798759 7f03883cd7c0 0 genericfilestorebackend(/var/lib/ceph/osd/ceph-0) detect_features: SEEK_DATA/SEEK_HOLE is disabled via 'filestore seek data hole' config option
2015-12-14 01:49:53.798807 7f03883cd7c0 0 genericfilestorebackend(/var/lib/ceph/osd/ceph-0) detect_features: splice is supported
2015-12-14 01:49:53.799981 7f03883cd7c0 0 genericfilestorebackend(/var/lib/ceph/osd/ceph-0) detect_features: syncfs(2) syscall fully supported (by glibc and kernel)
2015-12-14 01:49:53.800105 7f03883cd7c0 0 xfsfilestorebackend(/var/lib/ceph/osd/ceph-0) detect_features: extsize is supported and your kernel >= 3.5
2015-12-14 01:49:53.917696 7f03883cd7c0 0 filestore(/var/lib/ceph/osd/ceph-0) mount: enabling WRITEAHEAD journal mode: checkpoint is not enabled
2015-12-14 01:49:53.917897 7f03883cd7c0 -1 journal FileJournal::_open: disabling aio for non-block journal. Use journal_force_aio to force use of aio anyway
2015-12-14 01:49:53.917899 7f03883cd7c0 1 journal _open /var/lib/ceph/osd/ceph-0/journal fd 15: 5368709120 bytes, block size 4096 bytes, directio = 1, aio = 0
2015-12-14 01:49:53.918260 7f03883cd7c0 1 journal _open /var/lib/ceph/osd/ceph-0/journal fd 15: 5368709120 bytes, block size 4096 bytes, directio = 1, aio = 0
2015-12-14 01:49:53.918749 7f03883cd7c0 1 filestore(/var/lib/ceph/osd/ceph-0) upgrade
2015-12-14 01:49:53.918948 7f03883cd7c0 -1 filestore(/var/lib/ceph/osd/ceph-0) could not find -1/23c2fcde/osd_superblock/0 in index: (2) No such file or directory
2015-12-14 01:49:53.970546 7f03883cd7c0 1 journal close /var/lib/ceph/osd/ceph-0/journal
2015-12-14 01:49:53.971605 7f03883cd7c0 -1 created object store /var/lib/ceph/osd/ceph-0 journal /var/lib/ceph/osd/ceph-0/journal for osd.0 fsid 34704ace-c2c0-47f6-8540-9e8ce2d04c5a
2015-12-14 01:49:53.971696 7f03883cd7c0 -1 auth: error reading file: /var/lib/ceph/osd/ceph-0/keyring: can't open /var/lib/ceph/osd/ceph-0/keyring: (2) No such file or directory
2015-12-14 01:49:53.971949 7f03883cd7c0 -1 created new key in keyring /var/lib/ceph/osd/ceph-0/keyring
2015-12-14 03:38:34.975412 7f5bc0a787c0 0 ceph version 10.0.0-1055-g7f627e0 (7f627e04c8c939a1ddb8f01f74b9e7043ba54e42), process ceph-osd, pid 30504
2015-12-14 03:38:35.001311 7f5bc0a787c0 0 filestore(/var/lib/ceph/osd/ceph-0) backend xfs (magic 0x58465342)
2015-12-14 03:38:35.002549 7f5bc0a787c0 0 genericfilestorebackend(/var/lib/ceph/osd/ceph-0) detect_features: FIEMAP ioctl is disabled via 'filestore fiemap' config option
2015-12-14 03:38:35.002570 7f5bc0a787c0 0 genericfilestorebackend(/var/lib/ceph/osd/ceph-0) detect_features: SEEK_DATA/SEEK_HOLE is disabled via 'filestore seek data hole' config option
2015-12-14 03:38:35.002602 7f5bc0a787c0 0 genericfilestorebackend(/var/lib/ceph/osd/ceph-0) detect_features: splice is supported
2015-12-14 03:38:35.003382 7f5bc0a787c0 0 genericfilestorebackend(/var/lib/ceph/osd/ceph-0) detect_features: syncfs(2) syscall fully supported (by glibc and kernel)
2015-12-14 03:38:35.003565 7f5bc0a787c0 0 xfsfilestorebackend(/var/lib/ceph/osd/ceph-0) detect_features: extsize is supported and your kernel >= 3.5
2015-12-14 03:38:35.023805 7f5bc0a787c0 0 filestore(/var/lib/ceph/osd/ceph-0) mount: enabling WRITEAHEAD journal mode: checkpoint is not enabled
2015-12-14 03:38:35.024167 7f5bc0a787c0 -1 journal FileJournal::_open: disabling aio for non-block journal. Use journal_force_aio to force use of aio anyway
2015-12-14 03:38:35.024184 7f5bc0a787c0 1 journal _open /var/lib/ceph/osd/ceph-0/journal fd 19: 5368709120 bytes, block size 4096 bytes, directio = 1, aio = 0
2015-12-14 03:38:35.037433 7f5bc0a787c0 1 journal _open /var/lib/ceph/osd/ceph-0/journal fd 19: 5368709120 bytes, block size 4096 bytes, directio = 1, aio = 0
2015-12-14 03:38:35.038067 7f5bc0a787c0 1 filestore(/var/lib/ceph/osd/ceph-0) upgrade
2015-12-14 03:38:35.083760 7f5bc0a787c0 0 <cls> cls/hello/cls_hello.cc:305: loading cls_hello
2015-12-14 03:38:35.137222 7f5bc0a787c0 0 <cls> cls/cephfs/cls_cephfs.cc:202: loading cephfs_size_scan
2015-12-14 03:38:35.187230 7f5bc0a787c0 0 osd.0 0 crush map has features 33816576, adjusting msgr requires for clients
2015-12-14 03:38:35.187261 7f5bc0a787c0 0 osd.0 0 crush map has features 33816576 was 8705, adjusting msgr requires for mons
2015-12-14 03:38:35.187267 7f5bc0a787c0 0 osd.0 0 crush map has features 33816576, adjusting msgr requires for osds
2015-12-14 03:38:35.187355 7f5bc0a787c0 0 osd.0 0 load_pgs
2015-12-14 03:38:35.187400 7f5bc0a787c0 0 osd.0 0 load_pgs opened 0 pgs
2015-12-14 03:38:35.190445 7f5bc0a787c0 -1 osd.0 0 log_to_monitors {default=true}
2015-12-14 03:38:35.206336 7f5bc0a787c0 0 osd.0 0 done with init, starting boot process
2015-12-14 03:38:35.553742 7f5bae6ac700 0 osd.0 5 crush map has features 1107558400, adjusting msgr requires for clients
2015-12-14 03:38:35.553769 7f5bae6ac700 0 osd.0 5 crush map has features 1107558400 was 33825281, adjusting msgr requires for mons
2015-12-14 03:38:35.553781 7f5bae6ac700 0 osd.0 5 crush map has features 1107558400, adjusting msgr requires for osds

History

#1 Updated by Loic Dachary almost 4 years ago

  • Project changed from Ceph to Ceph-deploy
  • Category deleted (OSD)
  • Target version deleted (v10.0.4)

#2 Updated by Loic Dachary almost 4 years ago

  • Project changed from Ceph-deploy to Ceph

#3 Updated by Loic Dachary almost 4 years ago

  • Status changed from New to Need More Info
<alfredodeza> loicd: issue 14074 was moved to be ceph-deploy, but I am re-reading the ticket and can't see how this is a ceph-deploy issue
<alfredodeza> because (I quote): "I also tried a manual deployment, osd successful deployment, but can not start osd process." 

Could you please provide instructions about how to reproduce the problem without ceph-deploy being involved ? Thanks :-)

#4 Updated by Loic Dachary over 3 years ago

  • Status changed from Need More Info to Duplicate

Also available in: Atom PDF