Project

General

Profile

Bug #14047

rbd: rbd order will be place in 22, when set to 0 in the config_opt

Added by huanwen ren almost 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
Community (user)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

rbd order will be place in 22, when set to 0 in the config_opt

File:     librbd/Internal.cc
Function: 
librbd::create(IoCtx& io_ctx, const char *imgname, uint64_t size,
         ImageOptions& opts)
...
if (!order)
      order = cct->_conf->rbd_default_order;
    if (!order)
      order = RBD_DEFAULT_OBJ_ORDER;

    if (order > 25 || order < 12) {
      lderr(cct) << "order must be in the range [12, 25]" << dendl;
      return -EDOM;

#define RBD_DEFAULT_OBJ_ORDER    22   /* 4MB */

Associated revisions

Revision 16d50459 (diff)
Added by renhwztetecs almost 7 years ago

Delete rbd'order setup process

Delete rbd'order = RBD_DEFAULT_OBJ_ORDER process, when rbd'order is set to zero

Fixes: #14047
Signed-off-by: huanwen ren <>

Revision 4276fb3f (diff)
Added by renhwztetecs almost 7 years ago

Delete rbd'order define

Delete rbd'order define

Fixes: #14047
Signed-off-by: huanwen ren <>

History

#1 Updated by huanwen ren almost 7 years ago

Reason:

1.If set in the config_opt rbd_default_order = 0 (not in the range [12, 25]), due to reset the order = 22, so will not report errors

2.The current has increased the rbd'order judgment

#3 Updated by Nathan Cutler almost 7 years ago

  • Status changed from New to Fix Under Review

#4 Updated by Loïc Dachary almost 7 years ago

  • Project changed from Ceph to rbd

#5 Updated by Josh Durgin almost 7 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF