Project

General

Profile

Bug #14015

osd/PG.cc: 288: FAILED assert(info.last_epoch_started >= info.history.last_epoch_started)

Added by David Zafman almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
infernalis, hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Hit this assert when setting osd_find_best_info_ignore_history_les to get incomplete PGs to active+clean with known data loss.

Fixed in master with commit:
02a9a41f151a3d968bf8066749658659dc6e3ac4


Related issues

Copied to Ceph - Backport #14018: infernalis: osd/PG.cc: 288: FAILED assert(info.last_epoch_started >= info.history.last_epoch_started) Resolved
Copied to Ceph - Backport #14043: hammer: osd/PG.cc: 288: FAILED assert(info.last_epoch_started >= info.history.last_epoch_started) Resolved

History

#1 Updated by Loïc Dachary almost 6 years ago

  • Backport set to infernalis

#2 Updated by Loïc Dachary almost 6 years ago

  • Copied to Backport #14018: infernalis: osd/PG.cc: 288: FAILED assert(info.last_epoch_started >= info.history.last_epoch_started) added

#3 Updated by Loïc Dachary almost 6 years ago

@David, this is to be backported to infernalis ? Or also hammer ?

#4 Updated by David Zafman almost 6 years ago

  • Backport changed from infernalis to infernalis, hammer

We need to backport to Hammer too, so I added it.

#5 Updated by Ken Dreyer almost 6 years ago

  • Backport changed from infernalis, hammer to jewel, infernalis, hammer

#7 Updated by Loïc Dachary almost 6 years ago

  • Copied to Backport #14043: hammer: osd/PG.cc: 288: FAILED assert(info.last_epoch_started >= info.history.last_epoch_started) added

#8 Updated by Loïc Dachary almost 6 years ago

  • Backport changed from jewel, infernalis, hammer to infernalis, hammer

#10 Updated by Nathan Cutler almost 6 years ago

  • Status changed from Pending Backport to Resolved

#11 Updated by Loïc Dachary almost 6 years ago

  • Status changed from Resolved to New

@david: could this be a regression introduced by this fix ?

http://pulpito.ceph.com/loic-2016-02-16_22:00:52-rados-hammer-backports---basic-multi/12463/

2016-02-17T00:01:11.051 INFO:tasks.ceph.osd.1.mira080.stderr:2016-02-17 08:01:11.067384 7fb677316700 -1 osd.1 68 heartbeat_check: no reply from osd.5 since back 2016-02-17 08:00:49.045566 front 2016-02-17 08:00:49.045566 (cutoff 2016-02-17 08:00:51.067383)
2016-02-17T00:01:11.232 INFO:tasks.ceph.osd.4.smithi016.stderr:2016-02-17 08:01:11.240531 7f7b5ce5b700 -1 osd.4 68 heartbeat_check: no reply from osd.5 since back 2016-02-17 08:00:46.936030 front 2016-02-17 08:00:46.936030 (cutoff 2016-02-17 08:00:51.240529)
2016-02-17T00:01:12.673 INFO:tasks.ceph.osd.1.mira080.stderr:osd/PG.cc: In function 'void PG::proc_master_log(ObjectStore::Transaction&, pg_info_t&, pg_log_t&, pg_missing_t&, pg_shard_t)' thread 7fb666996700 time 2016-02-17 08:01:12.688125
2016-02-17T00:01:12.673 INFO:tasks.ceph.osd.1.mira080.stderr:osd/PG.cc: 303: FAILED assert(cct->_conf->osd_find_best_info_ignore_history_les || info.last_epoch_started >= info.history.last_epoch_started)
2016-02-17T00:01:12.674 INFO:tasks.ceph.osd.1.mira080.stderr: ceph version 0.94.5-372-gc8e5459 (c8e54591aa45fe42f3fd53164de8f89161696097)
2016-02-17T00:01:12.674 INFO:tasks.ceph.osd.1.mira080.stderr: 1: (ceph::__ceph_assert_fail(char const*, char const*, int, char const*)+0x8b) [0xbaa65b]
2016-02-17T00:01:12.674 INFO:tasks.ceph.osd.1.mira080.stderr: 2: (PG::proc_master_log(ObjectStore::Transaction&, pg_info_t&, pg_log_t&, pg_missing_t&, pg_shard_t)+0x34d) [0x7c83bd]
2016-02-17T00:01:12.674 INFO:tasks.ceph.osd.1.mira080.stderr: 3: (PG::RecoveryState::GetLog::react(PG::RecoveryState::GotLog const&)+0x1b1) [0x7e1141]
2016-02-17T00:01:12.674 INFO:tasks.ceph.osd.1.mira080.stderr: 4: (boost::statechart::simple_state<PG::RecoveryState::GetLog, PG::RecoveryState::Peering, boost::mpl::list<mpl_::

#12 Updated by Loïc Dachary almost 6 years ago

  • Status changed from New to Pending Backport

#13 Updated by Loïc Dachary almost 6 years ago

  • Status changed from Pending Backport to New

#14 Updated by Loïc Dachary over 5 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF