Project

General

Profile

Bug #13841

ceph-deploy failed on ubuntu14.04.1 because of apt-get don't have "--force-yes"

Added by bo cai almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
11/20/2015
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature:

Description

Is this a bug or something? Our Teuthology platform report this:
2015-11-20T11:11:37.815 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][WARNING]
2015-11-20T11:11:37.815 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][INFO ] Running command: sudo apt-key add release.asc
2015-11-20T11:11:37.882 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] OK
2015-11-20T11:11:37.883 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] add deb repo to /etc/apt/sources.list.d/
2015-11-20T11:11:37.885 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][INFO ] Running command: sudo env DEBIAN_FRONTEND=noninteractive DEBIAN_PRIORITY=critical apt-get --assume-yes -q update
2015-11-20T11:11:37.920 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Ign http://gitbuilder.ceph.com trusty InRelease
2015-11-20T11:11:37.920 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Ign http://gitbuilder.ceph.com trusty Release.gpg
2015-11-20T11:11:37.921 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Get:1 http://gitbuilder.ceph.com trusty Release [2,202 B]
2015-11-20T11:11:37.927 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Get:2 http://gitbuilder.ceph.com trusty/main amd64 Packages [7,300 B]
2015-11-20T11:11:37.931 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Get:3 http://gitbuilder.ceph.com trusty/main i386 Packages [387 B]
2015-11-20T11:11:37.995 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Ign http://gitbuilder.ceph.com trusty/main Translation-en_US
2015-11-20T11:11:37.995 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Ign http://gitbuilder.ceph.com trusty/main Translation-en
2015-11-20T11:11:37.995 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Fetched 9,889 B in 0s (138 kB/s)
2015-11-20T11:11:38.011 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Reading package lists...
2015-11-20T11:11:38.020 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][INFO ] Running command: sudo env DEBIAN_FRONTEND=noninteractive DEBIAN_PRIORITY=critical apt-get --assume-yes -q --no-install-recommends install -o Dpkg::Options::=--force-confnew ceph ceph-mds radosgw
2015-11-20T11:11:38.029 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Reading package lists...
2015-11-20T11:11:38.037 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Building dependency tree...
2015-11-20T11:11:38.037 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Reading state information...
2015-11-20T11:11:38.072 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Recommended packages:
2015-11-20T11:11:38.072 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] ceph-fs-common
2015-11-20T11:11:38.072 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] The following NEW packages will be installed:
2015-11-20T11:11:38.072 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] ceph ceph-mds radosgw
2015-11-20T11:11:38.072 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] 0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
2015-11-20T11:11:38.072 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] Need to get 0 B/20.8 MB of archives.
2015-11-20T11:11:38.072 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] After this operation, 99.5 MB of additional disk space will be used.
2015-11-20T11:11:38.073 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] WARNING: The following packages cannot be authenticated!
2015-11-20T11:11:38.073 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] ceph ceph-mds radosgw
2015-11-20T11:11:38.073 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][WARNING] E: There are problems and -y was used without --force-yes
2015-11-20T11:11:38.073 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][ERROR ] RuntimeError: command returned non-zero exit status: 100
2015-11-20T11:11:38.073 INFO:teuthology.orchestra.run.plana032.stderr:[ceph_deploy][ERROR ] RuntimeError: Failed to execute command: env DEBIAN_FRONTEND=noninteractive DEBIAN_PRIORITY=critical apt-get --assume-yes -q --no-install-recommends install -o Dpkg::Options::=--force-confnew ceph ceph-mds radosgw
2015-11-20T11:11:38.073 INFO:teuthology.orchestra.run.plana032.stderr:
2015-11-20T11:11:38.091 INFO:tasks.ceph_deploy:Error encountered, logging exception before tearing down ceph-deploy
2015-11-20T11:11:38.101 INFO:tasks.ceph_deploy:Traceback (most recent call last):
File "/home/teuthworker/src/ceph-qa-suite_master/tasks/ceph_deploy.py", line 227, in build_ceph_cluster
raise RuntimeError("ceph-deploy: Failed to install ceph")
RuntimeError: ceph-deploy: Failed to install ceph

teuthology.log View (275 KB) bo cai, 11/24/2015 12:47 AM

History

#1 Updated by Alfredo Deza almost 4 years ago

I don't think this is because apt doesn't have "--force-yes" (it does), but rather, I think apt is refusing to continue because
the packages are unauthenticated (pasted from the log output in the description):

2015-11-20T11:11:38.073 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] WARNING: The following packages cannot be authenticated!
2015-11-20T11:11:38.073 INFO:teuthology.orchestra.run.plana032.stderr:[plana032][DEBUG ] ceph ceph-mds radosgw

I am not sure in what circumstances this happened as I don't see output about the key being added to apt. Maybe a gitbuilder issue?

#2 Updated by bo cai almost 4 years ago

gitbuilder.com be redirected to our internal address by DNS server, our gitbuilder is a simple nginx that have some debs only, no key.
As you said , there may be key issues , but we added a "--force-yes" After that, it is no problem , consider whether to respond to a variety of circumstances , this option will be added to it ?

#3 Updated by bo cai almost 4 years ago

This is where a complete log of such failure

#4 Updated by Alfredo Deza almost 4 years ago

  • Status changed from New to Closed

Using "--force-yes" is not an option because we do sign out packages and using the force flag would ignore these warnings which are important.

Also available in: Atom PDF