Project

General

Profile

Bug #13840

Ceph Pools' MAX AVAIL is 0 if some OSDs' weight is 0

Added by Chengyuan Li over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
hammer, infernalis
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

After adding a new OSD and set its weight to 0, the pools' MAX AVAIL becomes 0 in "ceph df".

  1. ceph df
    GLOBAL:
    SIZE AVAIL RAW USED %RAW USED
    14694G 14694G 202M 0
    POOLS:
    NAME ID USED %USED MAX AVAIL OBJECTS
    rbd 0 0 0 0 0
    test2 1 0 0 0 0
    cephfs_data 2 0 0 0 0
    cephfs_metadata 3 2344 0 0 20
    cephfs2_data 4 0 0 0 0
    cephfs2_metadata 5 0 0 0 0
    rbd2 6 0 0 0 0

Related issues

Related to Ceph - Bug #10257: Ceph df doesn't report MAX AVAIL correctly when using rulesets and OSD in ruleset is down and out Resolved 12/05/2014
Copied to Ceph - Backport #13929: infernalis: Ceph Pools' MAX AVAIL is 0 if some OSDs' weight is 0 Resolved
Copied to Ceph - Backport #13930: hammer: Ceph Pools' MAX AVAIL is 0 if some OSDs' weight is 0 Resolved

History

#1 Updated by Zhiteng Huang over 4 years ago

This bug is related to http://tracker.ceph.com/issues/10257. And as pointed it out in https://bugzilla.redhat.com/show_bug.cgi?id=1225081, such bug 'significantly affects Openstack deployments' because Cinder RBD driver relies on 'df' result to report capacity to OpenStack Cinder scheduler. Please consider adjusting the priority of the bug as needed. Thanks.

#2 Updated by Nathan Cutler over 4 years ago

  • Related to Bug #10257: Ceph df doesn't report MAX AVAIL correctly when using rulesets and OSD in ruleset is down and out added

#3 Updated by Chengyuan Li over 4 years ago

Here is patch to fix this bug.
https://github.com/ceph/ceph/pull/6660

#4 Updated by David Medberry over 4 years ago

Effects my OpenStack. Lost ability to create cinder volumes today due to this issue.

#5 Updated by Ian Colle over 4 years ago

  • Status changed from New to Pending Backport
  • Assignee set to Loic Dachary
  • Backport set to Hammer, Infernalis

#6 Updated by Loic Dachary over 4 years ago

  • Backport changed from Hammer, Infernalis to hammer, infernalis

#7 Updated by Loic Dachary over 4 years ago

  • Copied to Backport #13929: infernalis: Ceph Pools' MAX AVAIL is 0 if some OSDs' weight is 0 added

#8 Updated by Loic Dachary over 4 years ago

  • Copied to Backport #13930: hammer: Ceph Pools' MAX AVAIL is 0 if some OSDs' weight is 0 added

#9 Updated by Nathan Cutler over 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF