Project

General

Profile

Bug #13727

TestClsRbd.snapshot failure

Added by Sage Weil about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Jason Dillaman
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
upgrade/hammer-x
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

2015-11-08T05:49:38.382 INFO:tasks.workunit.client.0.plana11.stdout:[ RUN      ] TestClsRbd.snapshots
2015-11-08T05:49:38.505 INFO:tasks.workunit.client.0.plana11.stdout:test/cls_rbd/test_cls_rbd.cc:789: Failure
2015-11-08T05:49:38.505 INFO:tasks.workunit.client.0.plana11.stdout:Value of: snap_names[0]
2015-11-08T05:49:38.505 INFO:tasks.workunit.client.0.plana11.stdout:  Actual: "snap1-rename" 
2015-11-08T05:49:38.505 INFO:tasks.workunit.client.0.plana11.stdout:Expected: "snap2" 
2015-11-08T05:49:38.505 INFO:tasks.workunit.client.0.plana11.stdout:[  FAILED  ] TestClsRbd.snapshots (123 ms)

http://qa-proxy.ceph.com/teuthology/teuthology-2015-11-08_05:00:08-smoke-master-distro-basic-multi/1141948/teuthology.log

Related issues

Duplicated by rbd - Bug #13767: ceph_test_cls_rbd: [ FAILED ] TestClsRbd.snapshots Duplicate 11/11/2015

Associated revisions

Revision 3b392267 (diff)
Added by Jason Dillaman about 7 years ago

tests: fix typo in TestClsRbd.snapshots test case

Fixes: #13727
Signed-off-by: Jason Dillaman <>

Revision 00a9ce74 (diff)
Added by Jason Dillaman about 7 years ago

tests: fix typo in TestClsRbd.snapshots test case

Fixes: #13727
Signed-off-by: Jason Dillaman <>
(cherry picked from commit 3b39226709b2fd7122b75fdab79a3cb87ec72d49)

History

#1 Updated by Sage Weil about 7 years ago

2015-11-08T13:17:24.980 INFO:tasks.workunit.client.0.plana96.stdout:[ RUN      ] TestClsRbd.add_remove_child
2015-11-08T13:17:25.070 INFO:tasks.workunit.client.0.plana96.stdout:test/cls_rbd/test_cls_rbd.cc:204: Failure
2015-11-08T13:17:25.070 INFO:tasks.workunit.client.0.plana96.stdout:Value of: get_children(&ioctx, oid, pspec, children)
2015-11-08T13:17:25.070 INFO:tasks.workunit.client.0.plana96.stdout:  Actual: -2
2015-11-08T13:17:25.071 INFO:tasks.workunit.client.0.plana96.stdout:Expected: 0
2015-11-08T13:17:25.071 INFO:tasks.workunit.client.0.plana96.stdout:[  FAILED  ] TestClsRbd.add_remove_child (90 ms)

on a test branch.. not sure if it's related? on this test both failed. /a/sage-2015-11-08_09:58:52-rados-wip-sage-testing---basic-multi/1142082

#2 Updated by Jason Dillaman about 7 years ago

  • Status changed from New to In Progress

#3 Updated by Jason Dillaman about 7 years ago

  • Status changed from In Progress to Fix Under Review
  • Assignee set to Jason Dillaman

#4 Updated by Jason Dillaman about 7 years ago

For 'TestClsRbd.add_remove_child', OSD log shows that a child was added to the image -- yet the get child call failed with -ENOENT:

http://qa-proxy.ceph.com/teuthology/sage-2015-11-08_09:58:52-rados-wip-sage-testing---basic-multi/1142082/remote/plana96/log/ceph-osd.0.log.gz

2015-11-08 13:17:25.042723 7f2728111700 10 osd.0 pg_epoch: 54 pg[17.6( v 54'1 (0'0,54'1] local-les=54 n=1 ec=53 les/c/f 54/54/0 53/53/53) [0,5] r=0 lpr=53 crt=0'0 lcod 0'0 mlcod 0'0 active+clean] do_osd_op 17/27aa1dd6/image3/head [call rbd.add_child]
...
2015-11-08 13:17:25.042872 7f2728111700 10 osd.0 pg_epoch: 54 pg[17.6( v 54'1 (0'0,54'1] local-les=54 n=1 ec=53 les/c/f 54/54/0 53/53/53) [0,5] r=0 lpr=53 crt=0'0 lcod 0'0 mlcod 0'0 active+clean] do_osd_op  omap-set-vals 0~0
2015-11-08 13:17:25.042884 7f2728111700 20 osd.0 pg_epoch: 54 pg[17.6( v 54'1 (0'0,54'1] local-les=54 n=1 ec=53 les/c/f 54/54/0 53/53/53) [0,5] r=0 lpr=53 crt=0'0 lcod 0'0 mlcod 0'0 active+clean] setting vals:
2015-11-08 13:17:25.042894 7f2728111700 20 osd.0 pg_epoch: 54 pg[17.6( v 54'1 (0'0,54'1] local-les=54 n=1 ec=53 les/c/f 54/54/0 53/53/53) [0,5] r=0 lpr=53 crt=0'0 lcod 0'0 mlcod 0'0 active+clean]     ^Q^@^@^@^@^@^@^@        ^@^@^@parent_id
^@^@^@^@^@^@^@
2015-11-08 13:17:25.044880 7f272590c700  1 -- 10.214.133.20:6800/16472 >> 10.214.133.20:0/234763132 conn(0x7f273f531000 sd=82 :6800 s=STATE_OPEN pgs=3 cs=1 l=1). == tx == 0x7f273f206b00 osd_op_reply(27 image3 [call rbd.add_child] v54'2 uv2 ack = 0) v6

2015-11-08 13:17:25.045586 7f2728111700 10 osd.0 pg_epoch: 54 pg[17.6( v 54'2 (0'0,54'2] local-les=54 n=1 ec=53 les/c/f 54/54/0 53/53/53) [0,5] r=0 lpr=53 luod=54'1 crt=0'0 lcod 0'0 mlcod 0'0 active+clean] do_op osd_op(client.4111.0:28 17.27aa1dd6 image3 [call rbd.get_children] snapc 0=[] ack+read+known_if_redirected e54) v7 may_read -> read-ordered flags ack+read+known_if_redirected
...
2015-11-08 13:17:25.061320 7f2728111700 10 osd.0 pg_epoch: 54 pg[17.6( v 54'2 (0'0,54'2] local-les=54 n=1 ec=53 les/c/f 54/54/0 53/53/53) [0,5] r=0 lpr=53 crt=0'0 lcod 54'1 mlcod 54'1 active+clean] call method rbd.get_children
2015-11-08 13:17:25.061353 7f2728111700 10 osd.0 pg_epoch: 54 pg[17.6( v 54'2 (0'0,54'2] local-les=54 n=1 ec=53 les/c/f 54/54/0 53/53/53) [0,5] r=0 lpr=53 crt=0'0 lcod 54'1 mlcod 54'1 active+clean] do_osd_op  omap-get-vals-by-keys 0~0
2015-11-08 13:17:25.061367 7f2728111700 15 filestore(/var/lib/ceph/osd/ceph-0) omap_get_values 17.6_head/17/27aa1dd6/image3/head
2015-11-08 13:17:25.061421 7f2728111700 15 filestore(/var/lib/ceph/osd/ceph-0) omap_get_values 17.6_head/17/27aa1dd6/image3/head = 0
...
2015-11-08 13:17:25.061457 7f2728111700  1 -- 10.214.133.20:6800/16472 >> 10.214.133.20:0/234763132 conn(0x7f273f531000 sd=82 :6800 s=STATE_OPEN pgs=3 cs=1 l=1). == tx == 0x7f273f4a8b00 osd_op_reply(28 image3 [call rbd.get_children] v0'0 uv2 ondisk = -2 ((2) No such file or directory)) v6

#5 Updated by Jason Dillaman about 7 years ago

Second issue covered by #13731

#6 Updated by Jason Dillaman about 7 years ago

  • Status changed from Fix Under Review to Resolved

#7 Updated by Yuri Weinstein about 7 years ago

  • Release set to jewel
  • ceph-qa-suite upgrade/hammer-x added

#8 Updated by Nathan Cutler about 7 years ago

  • Related to Bug #13767: ceph_test_cls_rbd: [ FAILED ] TestClsRbd.snapshots added

#9 Updated by Nathan Cutler about 7 years ago

  • Related to deleted (Bug #13767: ceph_test_cls_rbd: [ FAILED ] TestClsRbd.snapshots)

#10 Updated by Nathan Cutler about 7 years ago

  • Duplicated by Bug #13767: ceph_test_cls_rbd: [ FAILED ] TestClsRbd.snapshots added

#12 Updated by Jason Dillaman about 7 years ago

Fix is on master branch (looks like jewel branch was reset to master shortly between the bug introduction and its fix the next morning).

#14 Updated by Josh Durgin about 7 years ago

  • Status changed from New to Resolved

cherry-picked to jewel

Also available in: Atom PDF