Project

General

Profile

Bug #1367

cfuse and mon crash after dbench

Added by Josh Durgin about 9 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Tags:
Backport:
Regression:
Severity:
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:
Crash signature:

Description

This is from teuthology run 212 (logs in teuthology:~teuthworker/archive/full_suite_coverage_20110805/212/).
The relevant nodes, sepia{1,2,10} are still locked.
The backtraces:

2011-08-05T13:00:08.588 INFO:teuthology.task.cfuse.cfuse.0.err:*** Caught signal (Segmentation fault) **
2011-08-05T13:00:08.588 INFO:teuthology.task.cfuse.cfuse.0.err: in thread 0x7f84912c6700
2011-08-05T13:00:08.588 INFO:teuthology.task.cfuse.cfuse.0.err: ceph version 0.32-159-g66c3d8f (commit:66c3d8ff60ca585b97540daee942e2c5c6e5538f)
2011-08-05T13:00:08.588 INFO:teuthology.task.cfuse.cfuse.0.err: 1: /tmp/cephtest/binary/usr/local/bin/cfuse() [0x659774]
2011-08-05T13:00:08.589 INFO:teuthology.task.cfuse.cfuse.0.err: 2: (()+0xfb40) [0x7f8495543b40]
2011-08-05T13:00:08.589 INFO:teuthology.task.cfuse.cfuse.0.err: 3: (Client::remove_session_caps(int)+0x15d) [0x47260d]
2011-08-05T13:00:08.589 INFO:teuthology.task.cfuse.cfuse.0.err: 4: (Client::handle_client_session(MClientSession*)+0x65d) [0x4957cd]
2011-08-05T13:00:08.589 INFO:teuthology.task.cfuse.cfuse.0.err: 5: (Client::ms_dispatch(Message*)+0x5d3) [0x4c4313]
2011-08-05T13:00:08.589 INFO:teuthology.task.cfuse.cfuse.0.err: 6: (SimpleMessenger::dispatch_entry()+0x9d2) [0x524682]
2011-08-05T13:00:08.590 INFO:teuthology.task.cfuse.cfuse.0.err: 7: (SimpleMessenger::DispatchThread::entry()+0x2c) [0x457b8c]
2011-08-05T13:00:08.590 INFO:teuthology.task.cfuse.cfuse.0.err: 8: (Thread::_entry_func(void*)+0x12) [0x511bd2]
2011-08-05T13:00:08.590 INFO:teuthology.task.cfuse.cfuse.0.err: 9: (()+0x7971) [0x7f849553b971]
2011-08-05T13:00:08.590 INFO:teuthology.task.cfuse.cfuse.0.err: 10: (clone()+0x6d) [0x7f8493fcf92d]

and

2011-08-05T13:00:09.041 INFO:teuthology.task.ceph.mon.1.err:./common/Mutex.h: In function 'void Mutex::Lock(bool)', in thread '0x7f3f3c8e5700'
2011-08-05T13:00:09.041 INFO:teuthology.task.ceph.mon.1.err:./common/Mutex.h: 110: FAILED assert(r == 0)
2011-08-05T13:00:09.042 INFO:teuthology.task.ceph.mon.1.err: ceph version 0.32-159-g66c3d8f (commit:66c3d8ff60ca585b97540daee942e2c5c6e5538f)
2011-08-05T13:00:09.042 INFO:teuthology.task.ceph.mon.1.err: 1: (is_supported_auth(int, CephContext*)+0x829) [0x5a4249]
2011-08-05T13:00:09.042 INFO:teuthology.task.ceph.mon.1.err: 2: (get_auth_service_handler(CephContext*, KeyServer*, std::set<unsigned int, std::less<unsigned int>, std::allocator<unsigned int> >&)+
0x22) [0x62ea02]
2011-08-05T13:00:09.042 INFO:teuthology.task.ceph.mon.1.err: 3: (AuthMonitor::prep_auth(MAuth*, bool)+0x705) [0x525c55]
2011-08-05T13:00:09.043 INFO:teuthology.task.ceph.mon.1.err: 4: (AuthMonitor::preprocess_query(PaxosServiceMessage*)+0xbd) [0x52697d]
2011-08-05T13:00:09.043 INFO:teuthology.task.ceph.mon.1.err: 5: (PaxosService::dispatch(PaxosServiceMessage*)+0x93d) [0x49670d]
2011-08-05T13:00:09.043 INFO:teuthology.task.ceph.mon.1.err: 6: (Monitor::_ms_dispatch(Message*)+0xd19) [0x475f39]
2011-08-05T13:00:09.043 INFO:teuthology.task.ceph.mon.1.err: 7: (Monitor::ms_dispatch(Message*)+0xaf) [0x483e5f]
2011-08-05T13:00:09.043 INFO:teuthology.task.ceph.mon.1.err: 8: (SimpleMessenger::dispatch_entry()+0x9d2) [0x560e22]
2011-08-05T13:00:09.044 INFO:teuthology.task.ceph.mon.1.err: 9: (SimpleMessenger::DispatchThread::entry()+0x2c) [0x45a70c]
2011-08-05T13:00:09.044 INFO:teuthology.task.ceph.mon.1.err: 10: (Thread::_entry_func(void*)+0x12) [0x54de22]
2011-08-05T13:00:09.044 INFO:teuthology.task.ceph.mon.1.err: 11: (()+0x7971) [0x7f3f40559971]
2011-08-05T13:00:09.044 INFO:teuthology.task.ceph.mon.1.err: 12: (clone()+0x6d) [0x7f3f3efed92d]

Associated revisions

Revision 16a5761f (diff)
Added by Sage Weil about 9 years ago

client: don't falsely populate mds_sessions on bad MClientSession msg

If from isn't in the map, we don't want to add it via operator[].

Fixes: #1367
Signed-off-by: Sage Weil <>

History

#1 Updated by Sage Weil about 9 years ago

  • Target version set to v0.34
  • translation missing: en.field_position set to 797

#2 Updated by Sage Weil about 9 years ago

  • translation missing: en.field_position deleted (800)
  • translation missing: en.field_position set to 38

#3 Updated by Sage Weil about 9 years ago

nuked and unlocked nodes, nothing useful there.

#4 Updated by Sage Weil about 9 years ago

  • Target version changed from v0.34 to v0.35

#5 Updated by Sage Weil about 9 years ago

  • Status changed from New to Can't reproduce

#6 Updated by Sage Weil about 9 years ago

  • Category set to 1
  • Status changed from Can't reproduce to In Progress
  • Assignee set to Sage Weil

ok, just hit the top one after 35 runs.

#7 Updated by Sage Weil about 9 years ago

  • Status changed from In Progress to Resolved

#8 Updated by John Spray about 4 years ago

  • Project changed from Ceph to fs
  • Category deleted (1)
  • Target version deleted (v0.35)

Bulk updating project=ceph category=mds bugs so that I can remove the MDS category from the Ceph project to avoid confusion.

Also available in: Atom PDF