Project

General

Profile

Bug #13613

radosgw problems concurrent downloads

Added by Jiang Yu about 4 years ago. Updated about 4 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Target version:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
rgw
Pull request ID:
Crash signature:

Description

When I use java S3ObjectInputStream create 30 threads simultaneously download, there have been some problems.

The following is the use of java S3ObjectInputStream´╝Ü

byte[] buffer = new byte10240;
S3ObjectInputStream ins = conn.getObject(bucketName, objectName).getObjectContent();
while ((readSize = ins.read(buffer, 0, 10240)) != -1) {
//dosomething
}

radosgw log error´╝Ü
2015-10-27 08:55:59.275943 7fa3127fc700 0 ERROR: flush_read_list(): d->client_c->handle_data() returned -1
2015-10-27 08:55:59.282304 7fa3127fc700 20 get_obj_data::cancel_all_io()
2015-10-27 08:55:59.286948 7fa3127fc700 0 ERROR: s->cio->send_status() returned err=-1
2015-10-27 08:55:59.286977 7fa3127fc700 0 ERROR: s->cio->print() returned err=-1
2015-10-27 08:55:59.286979 7fa3127fc700 0 ERROR: s->cio->print() returned err=-1
2015-10-27 08:55:59.286981 7fa3127fc700 0 ERROR: s->cio->print() returned err=-1
2015-10-27 08:55:59.286983 7fa3127fc700 0 ERROR: s->cio->complete_header() returned err=-1
2015-10-27 08:55:59.287020 7fa3127fc700 2 req 797771:9.069599:s3:GET /gf1wfv/GF1_WFV3_E113.6_N35.6_20140225_L1A0000172299.TAR.GZ:get_obj:http status=403
2015-10-27 08:55:59.287031 7fa3127fc700 1 ====== req done req=0x7fa304007990 http_status=403 ======
2015-10-27 08:55:59.287078 7fa3127fc700 20 process_request() returned -1

History

#1 Updated by Samuel Just about 4 years ago

  • Project changed from Ceph to rgw
  • Category deleted (22)

#2 Updated by Yehuda Sadeh about 4 years ago

client timed out and disconnected. Can happen due to variety of issues, including configuration, hardware, client issues, etc.

#3 Updated by Jiang Yu about 4 years ago

Very grateful, we found some apache physical problem, the problem has been found

#4 Updated by Yehuda Sadeh about 4 years ago

  • Status changed from New to Rejected

Also available in: Atom PDF