Project

General

Profile

Bug #13605

rgw: object deletion might get bucket index state reset

Added by Guang Yang almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
10/26/2015
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

For object put/delete on rgw, it is implemented as multiple phrases:
  1. put a pending change into bucket index object
  2. put/delete the object itself
  3. complete the bucket index pending by either drop it or complete it (depending on step 2).
    The bug occurs during failure with either step 2 or step 3, which would left some pending changes on the bucket index, and at a later phrase, when the object is removed, it will check if there is pending change or not (this is on purpose because there could be multiple puts at the same time), and if it is, it would not remove the entry, but rather reset the entry.
    For a pending change, we will need to distinguish whether it is an on-going put, or a tombstone from a failure.

History

#1 Updated by Loic Dachary almost 4 years ago

  • Project changed from Ceph to rgw
  • Category deleted (22)

#2 Updated by Yehuda Sadeh almost 4 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF