Project

General

Profile

Bug #13602

daemons: pid/asok files are not removed upon daemon normal exit

Added by Guang Yang almost 4 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
10/26/2015
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

After stopping the the daemon, the corresponding pid/asok files are not automatically removed, there is a fix 24eb5647685ebba5e04e0171fae24033badca656 around that, but that looks more like a work-around (and hide the original problem) rather than a fix.

For asok file, it should be removed as part of CephContext's destructor.
For pid file, it should be removed by the atexist handler.

The reason why they don't get removed needs more investigation..

History

#1 Updated by Sage Weil over 2 years ago

  • Status changed from New to Resolved

i see atexit handlers for both pid files and asok files in master.

Also available in: Atom PDF