Project

General

Profile

Tasks #13571

hammer v0.94.5

Added by Loic Dachary over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Urgent
Target version:
% Done:

0%

Tags:
Reviewed:
Affected Versions:
Pull request ID:

Description

Workflow

  • Preparing the release IN PROGRESS
  • Cutting the release
    • Jason knows that Sage approves the release DONE
    • Jason gets approval from his lead SKIPPED (Sage approved)
      • Josh, RBD
    • Sage writes and commits the release notes IN PROGRESS
    • Jason informs Alfredo that the branch is ready for release DONE
    • Alfredo creates the packages and sets the release tag IN PROGRESS

Release information

git --no-pager log --format='%H %s' --graph tags/v0.94.4..ceph/hammer | perl -p -e 's/"/ /g; if (/\w+\s+Merge pull request #(\d+)/) { s|\w+\s+Merge pull request #(\d+).*|"Pull request $1":https://github.com/ceph/ceph/pull/$1|; } else { s|(\w+)\s+(.*)|"$2":https://github.com/ceph/ceph/commit/$1|; } s/\*/+/; s/^/* /;'

History

#1 Updated by Loic Dachary over 4 years ago

  • Assignee set to Jason Dillaman

#2 Updated by Loic Dachary over 4 years ago

git --no-pager log --format='%H %s' --graph tags/v0.94.4..ceph/wip-13559-hammer tags/v0.94.4..ceph/hammer | perl -p -e 's/"/ /g; if (/\w+\s+Merge pull request #(\d+)/) { s|\w+\s+Merge pull request #(\d+).*|"Pull request $1":https://github.com/ceph/ceph/pull/$1|; } else { s|(\w+)\s+(.*)|"$2":https://github.com/ceph/ceph/commit/$1|; } s/\*/+/; s/^/* /;'
  • + Pull request 6362
  • |\
  • | + osd/ReplicatedPG: remove stray debug line
  • |/
  • + Pull request 6330
  • + qa: Use public qemu repo
  • + librbd: potential assertion failure during cache read
  • + tests: reproduce crash during read-induced CoW
  • ...

    #3 Updated by Loic Dachary over 4 years ago

    teuthology-suite --priority 50 --suite wip-13567-hammer --subset $(expr $RANDOM % 5)/5 --suite-branch hammer --distro ubuntu --email loic@dachary.org --ceph wip-13559-hammer --machine-type plana,burnupi,mira teuthology-openstack --throttle 30 --simultaneous-jobs 40 --verbose --key-name myself --key-filename ~/Downloads/myself --filter='rbd/qemu/{cache/writeback.yaml cachepool/none.yaml clusters/fixed-3.yaml fs/btrfs.yaml msgr-failures/few.yaml workloads/qemu_xfstests.yaml}' --suite rbd --suite-branch wip-13567-hammer --distro ubuntu --ceph wip-13567-hammer
    208     [not run] src/aio-dio-regress/aio-dio-invalidate-failure not built
    209     [not run] src/aio-dio-regress/aio-dio-invalidate-readahead not built
    210     [not run] src/aio-dio-regress/aio-dio-subblock-eof-read not built
    211     [not run] src/aio-dio-regress/aio-free-ring-with-bogus-nr-pages not built
    212     [not run] src/aio-dio-regress/aio-io-setup-with-nonwritable-context-pointer not built
    213     0s
    214     0s
    215     2s
    216     46s
    217    
    

    timeout because it runs for more than 4h.

    #4 Updated by Loic Dachary over 4 years ago

    Verifying https://github.com/ceph/ceph/pull/6330 works as expected

    teuthology-openstack --throttle 30 --simultaneous-jobs 40 --verbose --key-name myself --key-filename ~/Downloads/myself --ceph-git-url http://github.com/ceph/ceph.git --ceph-qa-suite-git-url http://github.com/ceph/ceph-qa-suite.git --filter='rbd/singleton/{all/qemu-iotests-writethrough.yaml}' --suite rbd --suite-branch wip-13567-hammer-loic --distro ubuntu --ceph wip-13559-hammer

    #5 Updated by Loic Dachary over 4 years ago

    teuthology-suite --priority 50 --suite rbd --subset $(expr $RANDOM % 18)/18 --suite-branch wip-13567-hammer --distro ubuntu --email dillaman@redhat.com --ceph wip-13567-hammer --machine-type plana,burnupi,mira
    2015-10-23 01:59:20,824.824 INFO:teuthology.suite:Passed subset=3/18
    

    #6 Updated by Jason Dillaman over 4 years ago

    teuthology-suite -s rbd -c wip-13567-hammer -m plana,burnupi,mira --suite-branch wip-13567-hammer --filter "rbd/qemu/{cache/writeback.yaml cachepool/none.yaml clusters/fixed-3.yaml fs/btrfs.yaml msgr-failures/few.yaml workloads/qemu_xfstests.yaml}" -p 20 --email

    #7 Updated by Loic Dachary over 4 years ago

    • Description updated (diff)

    #8 Updated by Loic Dachary over 4 years ago

    • Description updated (diff)

    #9 Updated by Nathan Cutler over 4 years ago

    • Description updated (diff)

    #10 Updated by Nathan Cutler over 4 years ago

    • Status changed from In Progress to Resolved

    Also available in: Atom PDF