Project

General

Profile

Bug #1357

Making many pools and writing to them eventually hangs

Added by Greg Farnum about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OSD
Target version:
Start date:
08/04/2011
Due date:
% Done:

0%

Spent time:
Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

Discovered while testing #1297. Looping pool creates eventually hang when the OSD rejects writes for being sent earlier than same_primary_since on the PG.
Turns out that the OSD was initializing same_primary_since based on the osdmap epoch when the PG was created locally, not when it was entered into the map.

A Fix is in testing now.

History

#1 Updated by Greg Farnum about 8 years ago

  • Status changed from New to Testing

#2 Updated by Greg Farnum about 8 years ago

  • Status changed from Testing to In Progress

Well, I've found several different races and bugs. My current progress is in the wip-pg-creation branch, but there's still at least one issue creating...
Hopefully I can track it down tomorrow or on my way home.

#3 Updated by Greg Farnum about 8 years ago

  • Status changed from In Progress to Resolved

Ah, I didn't have quite the right fix in for the PGMonitor's PG creation (I was only setting it properly for the localized PGs -- whoops!).

This issue is now resolved. However, there is a similar one that crops up when creating new PGs in a pre-existing pool. I've made bug #1358 to track that.

Also available in: Atom PDF