Project

General

Profile

Bug #13437

TestClientLimits failing: not seeing the expected MDS log from stuck client tid updates

Added by Greg Farnum almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
Testing
Target version:
-
Start date:
10/09/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
infernalis
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

Here's one of them: http://qa-proxy.ceph.com/teuthology/teuthology-2015-10-06_23:04:02-fs-infernalis---basic-multi/1093450/

I've seen this a few times before. The one I investigated seemed to indicate that the client was not picking up on the config value which forces it to not flush its oldest tid, but I did not have enough evidence to indicate why.

Associated revisions

Revision b03ac079 (diff)
Added by Yan, Zheng almost 4 years ago

tasks/cephfs: fix TestClientLimits.test_client_oldest_tid

To get the health warning, first we need to make sure requests are
added to session's completed request list. Then we need to send an
extra request to MDS to trigger the code that generates the warning.

Fixes: #13437
Signed-off-by: Yan, Zheng <>

Revision b4caa058 (diff)
Added by Yan, Zheng almost 4 years ago

tasks/cephfs: fix TestClientLimits.test_client_oldest_tid

To get the health warning, first we need to make sure requests are
added to session's completed request list. Then we need to send an
extra request to MDS to trigger the code that generates the warning.

Fixes: #13437
Signed-off-by: Yan, Zheng <>
(cherry picked from commit b03ac0798058e543a80aaab88101314ab63dd22b)

History

#1 Updated by Zheng Yan almost 4 years ago

  • Status changed from New to Verified

the cause is that infernalis branch of ceph does not contain the client cap flush changes. but infernalis branch of ceph-qa-suite does.

#3 Updated by Greg Farnum almost 4 years ago

It's failing on master too: http://pulpito.ceph.com/teuthology-2015-10-09_23:04:01-fs-master---basic-multi/1098621/

And unless I messed up it should be in infernalis as well, although we might've gotten a couple runs that didn't match up. Will check when at a computer.

#4 Updated by Greg Farnum almost 4 years ago

Yeah, https://github.com/ceph/ceph/pull/4791 is in the infernalis branch!

#5 Updated by Zheng Yan almost 4 years ago

  • Status changed from Verified to Need Review

#6 Updated by John Spray almost 4 years ago

  • Status changed from Need Review to Pending Backport

Merged the fix to master, needs backport to infernalis

#7 Updated by John Spray almost 4 years ago

  • Status changed from Pending Backport to Resolved

Cherry picked onto infernalis.

Also available in: Atom PDF