Project

General

Profile

Bug #13424

wrong conditional for boolean function KeyServer::get_auth()

Added by Nathan Cutler about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

In src/auth/cephx/CephxServiceHandler.cc there is a conditional:

if (key_server->get_auth(entity_name, eauth) < 0) {
  ret = -EPERM;
  break;
}

As stated in #9756 this conditional will never fire because the function in question, KeyServer::get_auth() returns a boolean value that by definition will never be less than zero.


Related issues

Copied to Ceph - Backport #13425: wrong conditional for boolean function KeyServer::get_auth() Resolved

History

#2 Updated by Nathan Cutler about 7 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF