Project

General

Profile

Bug #13268

Secondary groups are not read /w SAMBA 4.2.2 & CEPHFS VFS module

Added by Dennis Kramer about 7 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
samba
Component(FS):
Labels (FS):
Samba/CIFS
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

Tested with a Windows 7 & 2008 client.

When I'm using the ceph_vfs module in SAMBA it seems secondary groups are not read for access to files and directories. It works when I use a kernel mount to cephfs which I share through SAMBA.

Also, ACLs (acl_xattr module) doesn't work either together with the ceph_vfs module.
Again, if I use a kernel mount for CEPHFS, ACLs work without any problems.


Related issues

Copied to CephFS - Backport #13809: hammer: Secondary groups are not read /w SAMBA 4.2.2 & CEPHFS VFS module Resolved

Associated revisions

Revision b13ddc06 (diff)
Added by Burkhard Linke almost 7 years ago

client: added permission check based on getgrouplist

Fixes: #13268
Signed-off-by: Yan, Zheng <>
(cherry picked from commit f04c8da5432174874ca97d11a5b2fef56f95d73d)

History

#1 Updated by Zheng Yan about 7 years ago

secondary groups should work if you use the newest developing code. I'am working on posix ACL supporting.

#2 Updated by Dennis Kramer about 7 years ago

You mean the development version of SAMBA? Which version?

#3 Updated by Dennis Kramer about 7 years ago

I have cloned https://github.com/ceph/samba.git but it doesn't work with secondary groups

#4 Updated by Loïc Dachary about 7 years ago

  • Target version deleted (v0.94.4)

#5 Updated by Zheng Yan about 7 years ago

development version of ceph

#6 Updated by Dennis Kramer about 7 years ago

Any news when the code hits the stable tree?

#7 Updated by Zheng Yan about 7 years ago

the code is included in infernalis

#8 Updated by Dennis Kramer about 7 years ago

Okay, very nice! What was the issue? I would've thought the issue would be in the samba ceph vfs module...

#9 Updated by Nathan Cutler about 7 years ago

If this is a bugfix and you want it backported to hammer, please:

  1. update this ticket with the commit hash(es) and/or PR number(s) of the fix
  2. update the Backport field of this ticket (e.g. "hammer")
  3. if the PR has been merged already, the status of this ticket should be changed to "Pending Backport"

This is only for Ceph backports, of course. If the fix is in Samba, ignore this message :-)

#10 Updated by Zheng Yan about 7 years ago

  • Status changed from New to Pending Backport
  • Target version set to v0.94.6

#11 Updated by Nathan Cutler about 7 years ago

https://github.com/ceph/ceph/pull/6604 is a backport, to hammer, of https://github.com/ceph/ceph/commit/f04c8da5432174874ca97d11a5b2fef56f95d73d which is one of three commits in https://github.com/ceph/ceph/pull/5528

What about the other two commits in that PR? Should they be backported as well?

#12 Updated by Nathan Cutler about 7 years ago

  • Target version deleted (v0.94.6)

Also, that PR claims to be fixing http://tracker.ceph.com/issues/12617 - what is the relationship between that issue and this one?

#13 Updated by Loïc Dachary about 7 years ago

  • Backport set to hammer

#14 Updated by Loïc Dachary about 7 years ago

  • Copied to Backport #13809: hammer: Secondary groups are not read /w SAMBA 4.2.2 & CEPHFS VFS module added

#15 Updated by Zheng Yan about 7 years ago

Nathan Cutler wrote:

https://github.com/ceph/ceph/pull/6604 is a backport, to hammer, of https://github.com/ceph/ceph/commit/f04c8da5432174874ca97d11a5b2fef56f95d73d which is one of three commits in https://github.com/ceph/ceph/pull/5528

What about the other two commits in that PR? Should they be backported as well?

I squash them into one commit

#16 Updated by Zheng Yan about 7 years ago

Nathan Cutler wrote:

Also, that PR claims to be fixing http://tracker.ceph.com/issues/12617 - what is the relationship between that issue and this one?

that one is for ceph-fuse. but the root cause is the same.

#17 Updated by Dennis Kramer about 7 years ago

Does the ceph samba_vfs also needs to be fixed? Upgrading to Infernalis doesn't resolve my issue. ACL's (acl_xattr in samba) still not working.

#18 Updated by Zheng Yan about 7 years ago

Dennis Kramer wrote:

Does the ceph samba_vfs also needs to be fixed? Upgrading to Infernalis doesn't resolve my issue. ACL's (acl_xattr in samba) still not working.

For ACL support, both libcephfs and samba require modification.

https://github.com/ceph/samba/tree/wip-acl
https://github.com/ceph/ceph/tree/wip-libcephfs-acl

#19 Updated by Dennis Kramer about 7 years ago

Does these modifications only need to be applied on a ceph client?

#20 Updated by Loïc Dachary over 6 years ago

  • Status changed from Pending Backport to Resolved

#21 Updated by Patrick Donnelly almost 4 years ago

  • Category deleted (43)
  • Labels (FS) Samba/CIFS added

Also available in: Atom PDF