Project

General

Profile

Backport #13210

tests : Fixed broken Makefiles after integration of lttng into rados

Added by Jason Dillaman about 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Release:
hammer
Crash signature (v1):
Crash signature (v2):

Associated revisions

Revision 2bd5d0b8 (diff)
Added by Sebastien Ponce about 7 years ago

radosstriper : Fixed broken Makefiles after integration of lttng

Fixes: #13210, backport of #6322 into hammer

Signed-off-by: Sebastien Ponce <>

History

#1 Updated by Jason Dillaman about 7 years ago

Backport https://github.com/sponce/ceph/commit/e4c27d804834b4a8bc495095ccf5103f8ffbcc1e to Hammer to fix the LTTng duplicate probe regisration issue.

#2 Updated by Loïc Dachary about 7 years ago

  • Status changed from New to Need More Info
  • Assignee set to Loïc Dachary

Could you please add a reference to a test that fails because of this in hammer ? It will help me make sure the backport is done right. Thanks !

#3 Updated by Sebastien Ponce about 7 years ago

This backport cannot be tested with the standard tests, and this is why the problem has not been detected in the releases. The problem is that tests are statically linked while this only arises when using dynamic libraries. The issue being that the librados.so and the libradosstriper.so have common symbols concerning lttng, as libradosstriper is badly build and has all symbols of librados on top of his own ones.

Besides, the simple cherry-picking won't work here, as the Makefile has been modified in the meantime.
Should I create a new branch with the fix properly backported so that you can merge easily ?

#5 Updated by Nathan Cutler about 7 years ago

  • Description updated (diff)

#6 Updated by Loïc Dachary about 7 years ago

  • Status changed from Need More Info to Resolved

#7 Updated by Loïc Dachary almost 7 years ago

  • Status changed from Resolved to In Progress

#8 Updated by Loïc Dachary almost 7 years ago

  • Status changed from In Progress to Resolved
  • Target version set to v0.94.6

Also available in: Atom PDF