Project

General

Profile

Bug #13189

Reboot systerm can not set up.

Added by ceph zte over 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
High
Assignee:
Category:
rbd
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
krbd
Crash signature:

Description

My system kernal is 3.10

The operation is below:

[root@client101 ~]# rbd map c1
/dev/rbd1
[root@client101 ~]# mount /dev/rbd1 /mnt
[root@client101 ~]# reboot

The the system can not stop.The screen continue to show the errors like below:

libceph:write mon socket errr;


Related issues

Related to Linux kernel client - Bug #20927: libceph does not give up reconnecting on broken network New 08/07/2017
Related to Linux kernel client - Bug #15887: client reboot stuck if the ceph node is not reachable or shutdown Won't Fix 05/13/2016

History

#1 Updated by Ilya Dryomov about 1 year ago

It hangs because the network is getting shut down before the filesystems on rbd devices are unmounted.

Getting this right is the job of the init system -- e.g. systemd can take care of this with rbdmap.service. Another option is mounting the filesystems with _netdev.

http://lists.ceph.com/pipermail/ceph-users-ceph.com/2019-January/032683.html
https://lists.freedesktop.org/archives/systemd-devel/2017-December/039937.html

#2 Updated by Ilya Dryomov about 1 year ago

  • Category set to rbd
  • Status changed from New to Closed
  • Assignee set to Ilya Dryomov

#3 Updated by Ilya Dryomov about 1 year ago

  • Related to Bug #20927: libceph does not give up reconnecting on broken network added

#4 Updated by Ilya Dryomov about 1 year ago

  • Related to Bug #15887: client reboot stuck if the ceph node is not reachable or shutdown added

Also available in: Atom PDF