Project

General

Profile

Bug #13129

qa: not starting ceph-mds daemons

Added by Greg Farnum almost 4 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Testing
Target version:
-
Start date:
09/16/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

http://pulpito.ceph.com/teuthology-2015-09-14_23:10:02-knfs-master-testing-basic-multi/1057697
http://pulpito.ceph.com/teuthology-2015-09-14_23:10:02-knfs-master-testing-basic-multi/1057705

These runs both "Timed out waiting for MDS daemons to become healthy". Grepping through the teuthology logs, it looks like they never invoked ceph-mds. How does that happen?!?!?

History

#1 Updated by Zheng Yan almost 4 years ago

  • Status changed from New to Verified

the bug is introduced by commit 685d76a77ca16ca601a99148ef507cfde1fb3593 "ceph: wait for CephFS to be healthy before proceeding. that commit adds a wait_for_daemons() to the funtion that setups MDS (the function does not start MDS)

#2 Updated by Greg Farnum almost 4 years ago

  • Status changed from Verified to Need More Info

That commit is now about 16 hours old, and these jobs were started about 24 hours ago — although they didn't get machines locked until after that commit...is that how the qa-suite works now? I thought it took what existed when it was scheduled.

#3 Updated by Greg Farnum almost 4 years ago

  • Status changed from Need More Info to Rejected

Also available in: Atom PDF