Project

General

Profile

Fix #12994

rbd-replay* should ship in ceph-common

Added by Ken Dreyer over 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
hammer
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

The rbd-replay* utilities are useful for Ceph users with RBD clients. Currently the rbd-replay* utilities ship in the "ceph-test" package, and we intend this ceph-test package for Ceph developers and contributors, not normal users.

We should move the rbd-replay* utilities to "ceph-common".


Related issues

Copied to devops - Backport #13172: rbd-replay* should ship in ceph-common Resolved

Associated revisions

Revision 96486fd6 (diff)
Added by Ken Dreyer about 7 years ago

packaging: move rbd-replay* to ceph-common

The rbd-replay* utilities are useful for Ceph users with RBD clients.
Currently the rbd-replay* utilities ship in the "ceph-test" package, and
we intend this ceph-test package for Ceph developers and contributors,
not normal users.

Move the rbd-replay* utilities to "ceph-common".

http://tracker.ceph.com/issues/12994 Fixes: #12994

Signed-off-by: Ken Dreyer <>

Revision 19c9546b (diff)
Added by Ken Dreyer about 7 years ago

packaging: move rbd-replay* to ceph-common

The rbd-replay* utilities are useful for Ceph users with RBD clients.
Currently the rbd-replay* utilities ship in the "ceph-test" package, and
we intend this ceph-test package for Ceph developers and contributors,
not normal users.

Move the rbd-replay* utilities to "ceph-common".

http://tracker.ceph.com/issues/12994 Fixes: #12994

Signed-off-by: Ken Dreyer <>
(cherry picked from commit 96486fd6f284ca3ab67f4f94631896d41c529e85)

Conflicts:
ceph.spec.in
50a33dea has not been backported to hammer
debian/ceph-test.install
50a33dea has not been backported to hammer
debian/control
different ceph-test Replaces: and Breaks: version

History

#1 Updated by Ken Dreyer over 7 years ago

  • Status changed from New to In Progress

Branch is "wip-12994-rbd-replay-packaging" in GitHub. I need to make sure that I've got the debian/control change correct, so that apt-get dist-upgrade will work cleanly. EDIT: I've tested installing ceph-test from Hammer, and then "apt-get upgrade ceph-common", and apt processes everything correctly.

#2 Updated by Ken Dreyer over 7 years ago

  • Status changed from In Progress to Fix Under Review

#3 Updated by Sage Weil about 7 years ago

  • Status changed from Fix Under Review to Resolved

#4 Updated by Ken Dreyer about 7 years ago

  • Status changed from Resolved to Pending Backport

#5 Updated by Josh Durgin about 7 years ago

A client-only upgrade test from hammer to infernalis on centos 7 failed due to rbd-replay-related binaries moving between packages:

2015-11-02T19:33:52.120 INFO:teuthology.orchestra.run.plana50:Running: 'sudo yum -y install libcephfs_jni1 rbd-fuse ceph-radosgw librbd1 ceph-debuginfo ceph-fuse python-ceph ceph ceph-devel librados2 cephfs-java libcephfs1'
...
2015-11-02T19:34:55.882 INFO:teuthology.orchestra.run.plana50.stderr:Transaction check error:
2015-11-02T19:34:55.882 INFO:teuthology.orchestra.run.plana50.stderr:  file /usr/bin/rbd-replay from install of ceph-common-1:9.1.0-103.gf66e576.el7.x86_64 conflicts with file from package ceph-test-1:0.94.5-0.el7.x86_64
2015-11-02T19:34:55.882 INFO:teuthology.orchestra.run.plana50.stderr:  file /usr/share/man/man8/rbd-replay-many.8.gz from install of ceph-common-1:9.1.0-103.gf66e576.el7.x86_64 conflicts with file from package ceph-test-1:0.94.5-0.el7.x86_64
2015-11-02T19:34:55.882 INFO:teuthology.orchestra.run.plana50.stderr:  file /usr/share/man/man8/rbd-replay-prep.8.gz from install of ceph-common-1:9.1.0-103.gf66e576.el7.x86_64 conflicts with file from package ceph-test-1:0.94.5-0.el7.x86_64
2015-11-02T19:34:55.882 INFO:teuthology.orchestra.run.plana50.stderr:  file /usr/share/man/man8/rbd-replay.8.gz from install of ceph-common-1:9.1.0-103.gf66e576.el7.x86_64 conflicts with file from package ceph-test-1:0.94.5-0.el7.x86_64

http://qa-proxy.ceph.com/teuthology/joshd-2015-11-02_11:29:16-upgrade:client-upgrade:hammer-client-x-infernalis---basic-multi/1136788/teuthology.log (search for Traceback)

is this a bug in the packaging, or the way the test is installing things?

#6 Updated by Ken Dreyer about 7 years ago

Thanks Josh, this could be fixed in the packaging.

The problem is that we've loosened the version dependencies between ceph-test and the rest of Ceph, so yum allows us to keep the Hammer-era ceph-test package on the system alongside the newer Infernalis ceph-common package, and these two conflict.

We should make Infernalis' ceph-common package require ceph-test > 9.1.0.

#7 Updated by Ken Dreyer about 7 years ago

We should make Infernalis' ceph-common package require ceph-test > 9.1.0.

Thinking more about this, we really don't want ceph-common to pull in ceph-test. So my theory about fixing this in the packaging is wrong, and we'll want to make the test suite code upgrade "ceph-test" along with all the others. (This would match what a typical user would do.)

#8 Updated by Josh Durgin about 7 years ago

For these tests we really only want to update the libraries, and run the old tests, to verify that we haven't broken the ABI. That's why we removed the exact-version-dependency for the ceph-test package. I'll see if we can get the upgrades to only libraries working without packaging changes.

#9 Updated by Loïc Dachary almost 7 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF