Project

General

Profile

Bug #1293

get_kernel_version fails with Linux 3.0

Added by Damien Churchill about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
OSD
Target version:
Start date:
07/08/2011
Due date:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

As the title says, get_kernel_version in FileJournal.cc fails due to expecting 3 parts to the version number and with 3.0 there are only 2 parts now.

2011-07-08 12:03:02.392361 7ff360984760 journal get_kernel_version: failed to parse string: 'Linux version 3.0-3-generic (buildd@rhenium) (gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4) ) #5~natty1-Ubuntu SMP Tue Jul 5'

History

#1 Updated by Sage Weil about 8 years ago

  • Category set to OSD
  • Target version set to v0.32

#2 Updated by Sage Weil about 8 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF