Project

General

Profile

Bug #12903

No longer able to host rbd images on cache-tier backed by EC pool

Added by Jason Dillaman over 6 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

http://qa-proxy.ceph.com/teuthology/teuthology-2015-08-31_23:00:07-rbd-master---basic-multi/1040026/teuthology.log

2015-09-01T05:30:02.075 INFO:teuthology.orchestra.run.burnupi13:Running: 'adjust-ulimits ceph-coverage /home/ubuntu/cephtest/archive/coverage rbd -p rbd create --size 10240 client.0.0'
2015-09-01T05:30:02.163 INFO:teuthology.orchestra.run.burnupi13.stderr:2015-09-01 05:30:02.158668 7f0938546840 -1 librbd: error adding image to directory: (95) Operation not supported
2015-09-01T05:30:02.165 INFO:teuthology.orchestra.run.burnupi13.stderr:rbd: create error: (95) Operation not supported

Related issues

Copied to Ceph - Backport #14762: hammer: No longer able to host rbd images on cache-tier backed by EC pool Closed

Associated revisions

Revision 8c2dfadb (diff)
Added by Zhiqiang Wang over 6 years ago

osd: force promote for ops which ec base pool can't handle

For ops which the ec base pool can't handle, if they are proxied to the
base ec pool, ENOTSUPP is returned. Need to force promote the objects
into the cache pool.

Fixes: #12903

Signed-off-by: Zhiqiang Wang <>

History

#1 Updated by Jason Dillaman over 6 years ago

  • Project changed from rbd to Ceph

Disabling proxy-write support fixes the issue.

#2 Updated by Loïc Dachary over 6 years ago

  • Status changed from New to In Progress
  • Assignee set to Loïc Dachary
  • Priority changed from Normal to Urgent

#3 Updated by Zhiqiang Wang over 6 years ago

This is because the tmap update op is proxied to the base ec tier, which doesn't support it, and ENOTSUPP will be returned when creating the rbd image.

#5 Updated by Loïc Dachary over 6 years ago

  • Assignee changed from Loïc Dachary to Zhiqiang Wang

#6 Updated by Josh Durgin over 6 years ago

  • Status changed from In Progress to Resolved

#7 Updated by Loïc Dachary almost 6 years ago

  • Status changed from Resolved to Pending Backport
  • Backport set to hammer

#8 Updated by Loïc Dachary almost 6 years ago

  • Copied to Backport #14762: hammer: No longer able to host rbd images on cache-tier backed by EC pool added

#9 Updated by Nathan Cutler about 5 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF