Project

General

Profile

Bug #12871

Could not find task 'ceph'

Added by Greg Farnum almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Core
Target version:
-
Start date:
08/31/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

2015-08-28T15:02:38.021 INFO:teuthology.run_tasks:Running task ceph...
2015-08-28T15:02:38.021 ERROR:teuthology.run_tasks:Saw exception from tasks.
Traceback (most recent call last):
  File "/home/teuthworker/src/teuthology_master/teuthology/run_tasks.py", line 53, in run_tasks
    manager = run_one_task(taskname, ctx=ctx, config=config)
  File "/home/teuthworker/src/teuthology_master/teuthology/run_tasks.py", line 35, in run_one_task
    task = import_task(submod)
  File "/home/teuthworker/src/teuthology_master/teuthology/run_tasks.py", line 23, in import_task
    raise ImportError("Could not find task '%s'" % name)
ImportError: Could not find task 'ceph'
2015-08-28T15:02:38.043 ERROR:teuthology.run_tasks: Sentry event: http://sentry.ceph.com/sepia/teuthology/search?q=744f2d734e314f0c8c62eed7d72a5806

http://pulpito.ceph.com/teuthology-2015-08-23_23:18:02-multimds-next-testing-basic-multi/1028568/, plus a lot more (57 failed, most of them on that) in that suite run.

History

#1 Updated by Andrew Schoen almost 4 years ago

This one is very curious, the only thing I can think of that might cause this is if somehow the ceph-qa-suite repo wasn't cloned, as that's where the ceph task lives. Have we seen this outside of this job?

#2 Updated by Zack Cerza almost 4 years ago

  • Status changed from New to Resolved

This is because ceph-qa-suite has no next branch. The crontab for sepia has since been updated to use infernalis for those runs.

Also available in: Atom PDF