Project

General

Profile

Bug #12796

missing libcephfs-jni1-devel package?...

Added by Greg Farnum almost 4 years ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
08/26/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

http://pulpito.ceph.redhat.com/teuthology-2015-08-22_18:12:02-hadoop-hammer---basic-magna/179587/

2015-08-26T01:09:21.618 INFO:teuthology.orchestra.run.magna117:Running: 'sudo yum install ceph-fuse -y'
2015-08-26T01:09:21.620 INFO:teuthology.orchestra.run.magna070.stdout:--> Finished Dependency Resolution
2015-08-26T01:09:21.632 INFO:teuthology.orchestra.run.magna070.stderr:Error: Package: 1:ceph-devel-compat-0.94.2-209.g697101e.el7.x86_64 (Ceph)
2015-08-26T01:09:21.661 INFO:teuthology.orchestra.run.magna070.stderr:           Requires: libcephfs_jni1-devel = 1:0.94.2-209.g697101e.el7
2015-08-26T01:09:21.662 INFO:teuthology.orchestra.run.magna070.stderr:           Available: 1:libcephfs_jni1-devel-0.94.2-209.g697101e.el7.x86_64 (Ceph)
2015-08-26T01:09:21.702 INFO:teuthology.orchestra.run.magna070.stderr:               libcephfs_jni1-devel = 1:0.94.2-209.g697101e.el7
2015-08-26T01:09:21.703 INFO:teuthology.orchestra.run.magna070.stdout: You could try using --skip-broken to work around the problem
2015-08-26T01:09:21.826 INFO:teuthology.orchestra.run.magna117.stdout:Loaded plugins: fastestmirror, langpacks, priorities, product-id, subscription-
2015-08-26T01:09:21.827 INFO:teuthology.orchestra.run.magna117.stdout:              : manager
2015-08-26T01:09:22.384 INFO:teuthology.orchestra.run.magna070.stdout:** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
2015-08-26T01:09:22.396 INFO:teuthology.orchestra.run.magna070.stdout:1:libcephfs_jni1-devel-0.94.2-209.g697101e.el7.x86_64 has missing requires of libcephfs_jni.so.1()(64bit)
2015-08-26T01:09:22.397 INFO:teuthology.orchestra.run.magna070.stdout:1:libcephfs_jni1-devel-0.94.2-209.g697101e.el7.x86_64 has missing requires of libcephfs_jni1 = ('1', '0.94.2', '209.g697101e.el7')
2015-08-26T01:09:22.430 INFO:teuthology.orchestra.run.magna050.stdout:Loading mirror speeds from cached hostfile
2015-08-26T01:09:22.467 ERROR:teuthology.parallel:Exception in parallel execution
Traceback (most recent call last):
  File "/home/teuthworker/src/teuthology_master/teuthology/parallel.py", line 82, in __exit__
    for result in self:
  File "/home/teuthworker/src/teuthology_master/teuthology/parallel.py", line 101, in next
    resurrect_traceback(result)
  File "/home/teuthworker/src/teuthology_master/teuthology/parallel.py", line 19, in capture_traceback
    return func(*args, **kwargs)
  File "/home/teuthworker/src/teuthology_master/teuthology/task/install.py", line 280, in _update_rpm_package_list_and_install
    remote.run(args=['sudo', 'yum', 'install', cpack, '-y'])
  File "/home/teuthworker/src/teuthology_master/teuthology/orchestra/remote.py", line 156, in run
    r = self._runner(client=self.ssh, name=self.shortname, **kwargs)
  File "/home/teuthworker/src/teuthology_master/teuthology/orchestra/run.py", line 378, in run
    r.wait()
  File "/home/teuthworker/src/teuthology_master/teuthology/orchestra/run.py", line 114, in wait
    label=self.label)
CommandFailedError: Command failed on magna070 with status 1: 'sudo yum install ceph-devel -y'

The libcephfs_jni bit is a bit suspicious, but the code there hasn't changed on the hammer branch in many months, so I think this must be some other kind of environment issue.

History

#1 Updated by Dan Mick over 3 years ago

  • Project changed from octo to devops
  • Subject changed from missing requires to missing libcephfs-jni1-devel package?...
  • Category deleted (Broken Host)

#2 Updated by Sage Weil over 1 year ago

  • Status changed from New to Rejected

Also available in: Atom PDF