Project

General

Profile

Bug #12779

valgrind failures in the monitor

Added by Greg Farnum almost 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
Monitor
Target version:
-
Start date:
08/25/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

2015-08-23T00:45:44.557 INFO:teuthology.orchestra.run.plana04:Running: "sudo zgrep '<kind>' /var/log/ceph/valgrind/* /dev/null | sort | uniq" 
2015-08-23T00:45:44.645 DEBUG:tasks.ceph:file /var/log/ceph/valgrind/mon.b.log kind   <kind>SyscallParam</kind>
2015-08-23T00:45:44.645 ERROR:tasks.ceph:saw valgrind issue   <kind>SyscallParam</kind> in /var/log/ceph/valgrind/mon.b.log
2015-08-23T00:45:44.645 DEBUG:tasks.ceph:file /var/log/ceph/valgrind/mon.b.log kind   <kind>UninitCondition</kind>
2015-08-23T00:45:44.645 ERROR:tasks.ceph:saw valgrind issue   <kind>UninitCondition</kind> in /var/log/ceph/valgrind/mon.b.log
2015-08-23T00:45:44.645 DEBUG:tasks.ceph:file /var/log/ceph/valgrind/mon.b.log kind   <kind>UninitValue</kind>
2015-08-23T00:45:44.645 ERROR:tasks.ceph:saw valgrind issue   <kind>UninitValue</kind> in /var/log/ceph/valgrind/mon.b.log

http://pulpito.ceph.com/teuthology-2015-08-21_23:04:01-fs-master---basic-multi/1025995/
http://pulpito.ceph.com/teuthology-2015-08-21_23:04:01-fs-master---basic-multi/1026036/
http://pulpito.ceph.com/teuthology-2015-08-21_23:04:01-fs-master---basic-multi/1026058/

Looks like this is also turning up in some recent rgw and rados runs, so it's not an FS thing.

History

#1 Updated by Sage Weil almost 4 years ago

  • Status changed from New to Duplicate

#2 Updated by Kefu Chai almost 4 years ago

we switched to libboost to generated uuid recently.

Also available in: Atom PDF