Project

General

Profile

Bug #12708

Even if RBD export-diff failure, will still create a local file

Added by bo cai about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
-
Start date:
08/17/2015
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

root@wfnd95:/caibo# clear
#there is no file in here
root@wfnd95:/caibo# ls
#i try to use export-diff,it must be fail because the snap don't exist
root@wfnd95:/caibo# rbd export-diff myblock@mysnap --from-snap not_exist_snap local_file
Exporting image: 0% complete...failed.
rbd: export-diff error: (2) No such file or directory
#but it still create a local file
root@wfnd95:/caibo# ls
local_file
root@wfnd95:/caibo#

History

#1 Updated by Kefu Chai about 4 years ago

  • Status changed from New to Pending Backport
  • Assignee set to bo cai

#2 Updated by Kefu Chai about 4 years ago

  • Project changed from Ceph to rbd

#3 Updated by Jason Dillaman about 4 years ago

  • Status changed from Pending Backport to Need Review

#4 Updated by Jason Dillaman about 4 years ago

  • Status changed from Need Review to Resolved

Also available in: Atom PDF