Project

General

Profile

Bug #12668

The install task fails to correctly check gitbuilder for debian

Added by Yuri Weinstein over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature:

History

#1 Updated by Andrew Schoen over 4 years ago

  • Project changed from devops to teuthology
  • Assignee changed from Ken Dreyer to Andrew Schoen

This is happening because on wheezy remote.os.codename returns an empty string. My recent refactoring of teuthology.task.install exposed this fact.

I think the correct way to solve this would be to have task.install use my new code at packaging.GitbuilderProject to find the version in the install task. We needed to do this anyway and it will correctly handle a missing codename. Eventually we should also fix remote.os.codename for debian.

#2 Updated by Andrew Schoen over 4 years ago

  • Subject changed from Missing http://gitbuilder.ceph.com/ceph-deb--x86_64-basic/ref/giant/version to The install task fails to correctly check gitbuilder for debian

#3 Updated by Andrew Schoen over 4 years ago

  • Status changed from New to 7

#4 Updated by Andrew Schoen over 4 years ago

  • Status changed from 7 to Fix Under Review

Also available in: Atom PDF