Project

General

Profile

Bug #12663

rpmkeys does not exist on EL6

Added by Travis Rhoden almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
ceph-deploy
Crash signature (v1):
Crash signature (v2):

Description

https://github.com/ceph/ceph-deploy/commit/d4d7d4b9a2e87546ba0d1db9178da7ae0308e187 introduced a regression for -EL6, in that 'rpmkeys' does not exist in EL6 distros.

This means that installs on CentOS6 are broken, and unfortunately that went into 1.5.27, even though our testing did catch it, I didn't see it. :/

Associated revisions

Revision a7c62280 (diff)
Added by Travis Rhoden almost 6 years ago

[RM-12663] use 'rpm --import', not 'rpmkeys --import'

for EL6 compatibility

Fixes: #12663

Signed-off-by: Travis Rhoden <>

Revision 3ec70132 (diff)
Added by Travis Rhoden over 5 years ago

[RM-12663] use 'rpm --import', not 'rpmkeys --import'

for EL6 compatibility

Fixes: #12663

Signed-off-by: Travis Rhoden <>
(cherry picked from commit a7c6228012f05e41e52fb8e3b9b8b650bcc5d708)

History

#1 Updated by Yuri Weinstein almost 6 years ago

  • Release set to hammer
  • ceph-qa-suite ceph-deploy added

This is for v0.94.3 QE validation

#2 Updated by Travis Rhoden almost 6 years ago

  • Status changed from New to Resolved

Went in with https://github.com/ceph/ceph-deploy/pull/343

Need to cut 1.5.28 to get it out.

Also available in: Atom PDF