Project

General

Profile

Bug #12640

radosgw + civetweb latency issue on Hammer

Added by Srikanth Madugundi over 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature (v1):
Crash signature (v2):

Description

After upgrading to Hammer and moving from apache to civetweb. We
started seeing high PUT latency in the order of 2 sec for every PUT
request. The GET request latency looks good.

Attaching the radosgw logs for a single request. The ceph.conf has the
following configuration for civetweb.

[client.radosgw.gateway]
rgw frontends = civetweb port=5632

Further investion reveled the call to get_data() at
https://github.com/ceph/ceph/blob/hammer/src/rgw/rgw_op.cc#L1786 is
taking 2 sec to respond. The cluster is on Hammer 94.2 release.

radosgw.log View (6.3 KB) Srikanth Madugundi, 08/06/2015 04:20 PM

History

#1 Updated by Yehuda Sadeh over 8 years ago

any chance you could provide a corresponding strace?

#2 Updated by Giridhar Yasa over 8 years ago

I am faced with the same issue, with AWS Java SDK based S3 client.

Looking at the packet trace, I found that this was happening because 'rgw print continue' was set to false (the default for ceph-ansible based deployments) and the client was waiting for 100-Continue. This doesn't happen with a Python Boto based client though.

If the OP can confirm this, we can close this as a non-bug.

#3 Updated by Yehuda Sadeh almost 8 years ago

  • Status changed from New to Closed

Also available in: Atom PDF