Project

General

Profile

Bug #12579

rbd map leads to system crash!

Added by bo cai about 4 years ago. Updated about 4 years ago.

Status:
Duplicate
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
07/30/2015
Due date:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature:

Description

#I create a rbd block named r1
rbd -p rbd create r1 --size 1024

#then create a snapshot of r1
rbd -p rbd snap create --image r1 --snap r1-s1

#then protect this snapshot and clone a new block from this snapshot
rbd snap protect --image r1 --snap r1-s1
rbd clone --image r1 --snap r1-s1 --dest r2

#then create a snapshot of r2 , protect the snapshot , clone a new block named r3
rbd snap create --image r2 --snap r2-s1
rbd snap protect --image r2 --snap r2-s1
rbd clone --image r2 --snap r2-s1 --dest r3

#Do the same thing as above, loop 100 times (for example, you can cycle more)

#then I get a block named r101(get from 100 times clone)
#then I try to map this block?I use this command
rbd -p rbd map r101

#then my system crash
#In the below picture,You can see some infomation about system crash

This happens in the real machine, rather than the virtual machine, and I also tested on the virtual machine, found the same problem

rbdmap-crash.png View (155 KB) bo cai, 07/30/2015 05:41 AM


Related issues

Duplicates Linux kernel client - Bug #12538: An image with a long clone chain blows up kernel stack Resolved 07/30/2015

History

#1 Updated by Loic Dachary about 4 years ago

  • Project changed from rbd to Linux kernel client
  • Status changed from New to Duplicate
  • Target version deleted (v0.94.3)

Duplicate of #12538

Also available in: Atom PDF