Project

General

Profile

Bug #12564

ansible-playbook fails cgroup-lite : Conflicts: cgroup-bin but 0.37.1-1ubuntu10.1 is to be installed

Added by Loic Dachary almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature:

Description

It's probably not mysterious but it looks like it is because there is no error message, just a failure at http://pulpito.ceph.com/loic-2015-08-02_10:14:05-rgw-wip-12502-hammer---basic-multi/995449/

2015-08-02T01:45:15.053 INFO:teuthology.task.ansible.out:changed: [plana93.front.sepia.ceph.com] => {"changed": true, "name": "nagios-nrpe-server", "state": "started"}

PLAY [cobbler] **************************************************************** 
skipping: no hosts matched

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/var/lib/teuthworker/cephlab.retry

plana89.front.sepia.ceph.com : ok=36   changed=0    unreachable=0    failed=1   
plana93.front.sepia.ceph.com : ok=74   changed=22   unreachable=0    failed=0   

2015-08-02T01:45:15.171 ERROR:teuthology.run_tasks:Saw exception from tasks.
Traceback (most recent call last):
  File "/home/teuthworker/src/teuthology_master/teuthology/run_tasks.py", line 56, in run_tasks
    manager.__enter__()
  File "/home/teuthworker/src/teuthology_master/teuthology/task/__init__.py", line 121, in __enter__
    self.begin()
  File "/home/teuthworker/src/teuthology_master/teuthology/task/ansible.py", line 221, in begin
    self.execute_playbook()
  File "/home/teuthworker/src/teuthology_master/teuthology/task/ansible.py", line 245, in execute_playbook
    raise CommandFailedError(command, status)
CommandFailedError: Command failed with status 2: 'ansible-playbook -v --extra-vars \'{"ansible_ssh_user": "ubuntu"}\' -i /etc/ansible/hosts --limit plana89.front.sepia.ceph.com,plana93.front.sepia.ceph.com /var/lib/teuthworker/src/ceph-cm-ansible_master/cephlab.yml'
2015-08-02T01:45:15.198 ERROR:teuthology.run_tasks: Sentry event: http://sentry.ceph.com/sepia/teuthology/search?q=ea6e693dcaae4c20a110f8d8ff8e2169
CommandFailedError: Command failed with status 2: 'ansible-playbook -v --extra-vars \'{"ansible_ssh_user": "ubuntu"}\' -i /etc/ansible/hosts --limit plana89.front.sepia.ceph.com,plana93.front.sepia.ceph.com /var/lib/teuthworker/src/ceph-cm-ansible_master/cephlab.yml'

History

#1 Updated by Loic Dachary almost 5 years ago

I'm marking this as Urgent because it blocks the validation of http://tracker.ceph.com/issues/12502 which blocks v0.94.3

#2 Updated by Loic Dachary almost 5 years ago

  • Subject changed from ansible-playbook fails mysteriously to ansible-playbook fails cgroup-lite : Conflicts: cgroup-bin but 0.37.1-1ubuntu10.1 is to be installed

Browsing the log back, I found:

Building dependency tree...
Reading state information...
libdm0 is already the newest version.
libfcgi0ldbl is already the newest version.
Some packages could not be i
2015-08-02T01:45:05.006 INFO:teuthology.task.ansible.out:nstalled. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cgroup-lite : Conflicts: cgroup-bin but 0.37.1-1ubuntu10.1 is to be installed

msg: '/usr/bin/apt-get -y -o "Dpkg::Options::=--force-confdef" -o "Dpkg::Options::=--force-confold"   install 'kvm' 'libfcgi' 'dmapi' 'tgt' 'cgroup-lite' 'cgroup-bin'' failed: E: Unable to correct problems, you have held broken packages.


#3 Updated by Andrew Schoen almost 5 years ago

I think this should take care of it. I merged a PR last week that is causing this.

https://github.com/ceph/ceph-cm-ansible/pull/95

Also available in: Atom PDF