Project

General

Profile

Bug #12480

install to fc22: does not upgrade (or downgrade) ceph

Added by Sage Weil almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

[root@vpm056 ubuntu]# rpm -qa | grep ceph
libcephfs1-9.0.1-1299.g5832cdd.fc22.x86_64
python-cephfs-9.0.1-1299.g5832cdd.fc22.x86_64
ceph-common-9.0.1-1299.g5832cdd.fc22.x86_64
ceph-radosgw-9.0.1-1299.g5832cdd.fc22.x86_64
ceph-9.0.1-1299.g5832cdd.fc22.x86_64

then i try to install a newer version (v9.0.1-1302-gfb24f2f)

gnit:ceph-deploy (master) 02:16 PM $ ./ceph-deploy install --dev=wip-systemd vpm056.front.sepia.ceph.com
[ceph_deploy.conf][DEBUG ] found configuration file at: /home/sage/.cephdeploy.conf
[ceph_deploy.cli][INFO  ] Invoked (1.5.26): ./ceph-deploy install --dev=wip-systemd vpm056.front.sepia.ceph.com
[ceph_deploy.cli][INFO  ] ceph-deploy options:
[ceph_deploy.cli][INFO  ]  verbose                       : False
[ceph_deploy.cli][INFO  ]  testing                       : None
[ceph_deploy.cli][INFO  ]  cd_conf                       : <ceph_deploy.conf.cephdeploy.Conf instance at 0x7f593f4c2b48>
[ceph_deploy.cli][INFO  ]  cluster                       : ceph
[ceph_deploy.cli][INFO  ]  install_mds                   : False
[ceph_deploy.cli][INFO  ]  stable                        : None
[ceph_deploy.cli][INFO  ]  prog                          : ceph-deploy install
[ceph_deploy.cli][INFO  ]  default_release               : False
[ceph_deploy.cli][INFO  ]  username                      : None
[ceph_deploy.cli][INFO  ]  adjust_repos                  : True
[ceph_deploy.cli][INFO  ]  func                          : <function install at 0x7f593f910230>
[ceph_deploy.cli][INFO  ]  install_all                   : False
[ceph_deploy.cli][INFO  ]  repo                          : False
[ceph_deploy.cli][INFO  ]  host                          : ['vpm056.front.sepia.ceph.com']
[ceph_deploy.cli][INFO  ]  install_rgw                   : False
[ceph_deploy.cli][INFO  ]  repo_url                      : None
[ceph_deploy.cli][INFO  ]  ceph_conf                     : None
[ceph_deploy.cli][INFO  ]  install_osd                   : False
[ceph_deploy.cli][INFO  ]  version_kind                  : dev
[ceph_deploy.cli][INFO  ]  install_common                : False
[ceph_deploy.cli][INFO  ]  overwrite_conf                : False
[ceph_deploy.cli][INFO  ]  quiet                         : False
[ceph_deploy.cli][INFO  ]  dev                           : wip-systemd
[ceph_deploy.cli][INFO  ]  local_mirror                  : None
[ceph_deploy.cli][INFO  ]  release                       : None
[ceph_deploy.cli][INFO  ]  install_mon                   : False
[ceph_deploy.cli][INFO  ]  gpg_url                       : None
[ceph_deploy.install][DEBUG ] Installing dev version wip-systemd on cluster ceph hosts vpm056.front.sepia.ceph.com
[ceph_deploy.install][DEBUG ] Detecting platform for host vpm056.front.sepia.ceph.com ...
X11 forwarding request failed on channel 0
[vpm056.front.sepia.ceph.com][DEBUG ] connection detected need for sudo
X11 forwarding request failed on channel 0
[vpm056.front.sepia.ceph.com][DEBUG ] connected to host: vpm056.front.sepia.ceph.com 
[vpm056.front.sepia.ceph.com][DEBUG ] detect platform information from remote host
[vpm056.front.sepia.ceph.com][DEBUG ] detect machine type
[ceph_deploy.install][INFO  ] Distro info: Fedora 22 Twenty Two
[vpm056.front.sepia.ceph.com][INFO  ] installing ceph on vpm056.front.sepia.ceph.com
[vpm056.front.sepia.ceph.com][DEBUG ] Configure Yum priorities to include obsoletes
[vpm056.front.sepia.ceph.com][WARNIN] check_obsoletes has been enabled for Yum priorities plugin
[vpm056.front.sepia.ceph.com][INFO  ] skipping install of ceph-release package
[vpm056.front.sepia.ceph.com][INFO  ] repo file will be created manually
[vpm056.front.sepia.ceph.com][INFO  ] Running command: sudo yum clean all
[vpm056.front.sepia.ceph.com][WARNIN] Yum command has been deprecated, redirecting to '/usr/bin/dnf clean all'.
[vpm056.front.sepia.ceph.com][WARNIN] See 'man dnf' and 'man yum2dnf' for more information.
[vpm056.front.sepia.ceph.com][WARNIN] To transfer transaction metadata from yum to DNF, run:
[vpm056.front.sepia.ceph.com][WARNIN] 'dnf install python-dnf-plugins-extras-migrate && dnf-2 migrate'
[vpm056.front.sepia.ceph.com][WARNIN] 
[vpm056.front.sepia.ceph.com][DEBUG ] Cleaning repos: fedora ceph-noarch ceph updates
[vpm056.front.sepia.ceph.com][DEBUG ] Cleaning up Everything
[vpm056.front.sepia.ceph.com][INFO  ] Running command: sudo rpm --import https://git.ceph.com/?p=ceph.git;a=blob_plain;f=keys/autobuild.asc
[vpm056.front.sepia.ceph.com][DEBUG ] set the contents of repo file to /etc/yum.repos.d/
[vpm056.front.sepia.ceph.com][INFO  ] Running command: sudo yum -y install yum-plugin-priorities
[vpm056.front.sepia.ceph.com][WARNIN] Yum command has been deprecated, redirecting to '/usr/bin/dnf -y install yum-plugin-priorities'.
[vpm056.front.sepia.ceph.com][WARNIN] See 'man dnf' and 'man yum2dnf' for more information.
[vpm056.front.sepia.ceph.com][WARNIN] To transfer transaction metadata from yum to DNF, run:
[vpm056.front.sepia.ceph.com][WARNIN] 'dnf install python-dnf-plugins-extras-migrate && dnf-2 migrate'
[vpm056.front.sepia.ceph.com][WARNIN] 
[vpm056.front.sepia.ceph.com][DEBUG ] Last metadata expiration check performed 0:00:05 ago on Mon Jul 27 19:26:05 2015.
[vpm056.front.sepia.ceph.com][WARNIN] Package yum-plugin-priorities-1.1.31-505.fc22.noarch is already installed, skipping.
[vpm056.front.sepia.ceph.com][DEBUG ] Dependencies resolved.
[vpm056.front.sepia.ceph.com][DEBUG ] Nothing to do.
[vpm056.front.sepia.ceph.com][DEBUG ] Complete!
[vpm056.front.sepia.ceph.com][WARNIN] alter.d ceph.repo priorities to contain: priority=1
[vpm056.front.sepia.ceph.com][WARNIN] ensuring that /etc/yum.repos.d/ceph.repo contains a high priority
[vpm056.front.sepia.ceph.com][WARNIN] altered ceph.repo priorities to contain: priority=1
[vpm056.front.sepia.ceph.com][INFO  ] Running command: sudo dnf -y install ceph ceph-radosgw
[vpm056.front.sepia.ceph.com][DEBUG ] Last metadata expiration check performed 0:00:11 ago on Mon Jul 27 19:26:05 2015.
[vpm056.front.sepia.ceph.com][WARNIN] Package ceph-1:9.0.1-1299.g5832cdd.fc22.x86_64 is already installed, skipping.
[vpm056.front.sepia.ceph.com][WARNIN] Package ceph-radosgw-1:9.0.1-1299.g5832cdd.fc22.x86_64 is already installed, skipping.
[vpm056.front.sepia.ceph.com][DEBUG ] Dependencies resolved.
[vpm056.front.sepia.ceph.com][DEBUG ] Nothing to do.
[vpm056.front.sepia.ceph.com][DEBUG ] Complete!
[vpm056.front.sepia.ceph.com][INFO  ] Running command: sudo ceph --version
[vpm056.front.sepia.ceph.com][DEBUG ] ceph version 9.0.1-1299-g5832cdd (5832cddc33c44095bfc52129a62f3cbd90016a75)

Associated revisions

Revision bccbca0a (diff)
Added by Travis Rhoden almost 6 years ago

[RM-12480] Allow kwargs and extra_install_flags for install()

Refs: #12480

Signed-off-by: Travis Rhoden <>

Revision 55547662 (diff)
Added by Travis Rhoden almost 6 years ago

[RM-12480] Use "dnf install --best" so that upgrades happen

Fixes: #12480

Signed-off-by: Travis Rhoden <>

History

#1 Updated by Ian Colle almost 6 years ago

  • Assignee set to Travis Rhoden

#2 Updated by Ian Colle almost 6 years ago

  • Status changed from New to 12

#3 Updated by Travis Rhoden almost 6 years ago

  • Status changed from 12 to Fix Under Review
  • Target version set to 1.5.27

#4 Updated by Travis Rhoden almost 6 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF