Project

General

Profile

Bug #12381

nodes are missing dbench

Added by Greg Farnum about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Start date:
07/17/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

http://pulpito.ceph.com/teuthology-2015-07-14_23:04:02-fs-next---basic-multi/974430/

2015-07-16T12:10:07.279 INFO:tasks.workunit.client.0.plana35.stderr:/home/ubuntu/cephtest/workunit.client.0/suites/dbench.sh: line 5: dbench: command not found
2015-07-16T12:10:07.280 INFO:tasks.workunit:Stopping ['suites/dbench.sh'] on client.0...
2015-07-16T12:10:07.280 INFO:teuthology.orchestra.run.plana35:Running: 'rm -rf -- /home/ubuntu/cephtest/workunits.list.client.0 /home/ubuntu/cephtest/workunit.client.0'
2015-07-16T12:10:07.352 ERROR:teuthology.parallel:Exception in parallel execution

I went and checked on the node and it indeed does not have dbench installed. I checked plana34 and dbench is present. Apologies if this is the wrong tracker but I suspect it's a result of the switch from Chef to Ansible...

History

#1 Updated by Andrew Schoen about 4 years ago

We're definitely installing it with ansible, you can see it in the packages list for all the distros here.

https://github.com/ceph/ceph-cm-ansible/search?utf8=%E2%9C%93&q=dbench

#2 Updated by Andrew Schoen about 4 years ago

Hmm, it seemed to skip installing packages for plana35.

2015-07-16T12:04:24.302 INFO:teuthology.task.ansible.out:
TASK: [testnode | Install packages] ******************************************* 

2015-07-16T12:04:24.346 INFO:teuthology.task.ansible.out:skipping: [plana35.front.sepia.ceph.com]

#3 Updated by Andrew Schoen about 4 years ago

It looks to be skipping every play for plana35. It looks like plana35 does exist in sepia-secrets though.

Also available in: Atom PDF