Project

General

Profile

Bug #12366

linking ceph to tcmalloc causes segfault on SUSE SLE11-SP3

Added by Nathan Cutler about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
07/16/2015
Due date:
% Done:

0%

Source:
Community (dev)
Tags:
Backport:
hammer,firefly
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

The issue is believed to only occur on 64 bit.

If you link ceph to tcmalloc the system will segfault on SLE11sp3.

If you do not link ceph to gperftools tcmalloc implementation ceph-mon does not crash on SLE11sp3.


Related issues

Copied to devops - Backport #12367: linking ceph to tcmalloc causes segfault on SUSE SLE11-SP3 Rejected 07/16/2015
Copied to devops - Backport #12368: linking ceph to tcmalloc causes segfault on SUSE SLE11-SP3 Resolved 07/16/2015

History

#1 Updated by Nathan Cutler about 4 years ago

  • Status changed from New to Pending Backport

#2 Updated by Nathan Cutler about 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF