Project

General

Profile

Bug #12357

kclient: some kind of hang

Added by Greg Farnum about 4 years ago. Updated about 3 years ago.

Status:
Won't Fix
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
07/16/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
kceph
Labels (FS):
Pull request ID:

Description

http://pulpito.ceph.redhat.com/teuthology-2015-07-12_18:08:02-kcephfs-hammer-testing-basic-magna/151448/

It looks like the MDS didn't start up quickly enough for some reason and got blacklisted, and at a later point (don't know if it's related) the kernel client hung on the trivial sync workunit. That directory includes the full kern.log.

History

#1 Updated by Zheng Yan about 4 years ago

  • Status changed from New to Won't Fix
2015-07-15T02:10:18.585 INFO:tasks.workunit.client.0.magna070.stderr:tar (child): bzip2: Cannot exec: No such file or directory
2015-07-15T02:10:18.586 INFO:tasks.workunit.client.0.magna070.stderr:tar (child): Error is not recoverable: exiting now
2015-07-15T02:10:18.587 INFO:tasks.workunit.client.0.magna070.stderr:tar: Child returned status 2
2015-07-15T02:10:18.588 INFO:tasks.workunit.client.0.magna070.stderr:tar: Error is not recoverable: exiting now

the failure caused by missing bzip2

#2 Updated by Greg Farnum about 4 years ago

Sorry I missed that. I believe the missing bzip2 is being handled elsewhere by the teuthology guys.

#3 Updated by Greg Farnum about 3 years ago

  • Component(FS) kceph added

Also available in: Atom PDF