Project

General

Profile

Actions

Bug #12259

closed

use dnf for fedora 22+

Added by Sage Weil almost 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Travis Rhoden
Target version:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

[vpm048][INFO  ] Running command: sudo yum -y install yum-plugin-priorities
[vpm048][WARNIN] Yum command has been deprecated, redirecting to '/usr/bin/dnf -y install yum-plugin-priorities'.
[vpm048][WARNIN] See 'man dnf' and 'man yum2dnf' for more information.
[vpm048][WARNIN] To transfer transaction metadata from yum to DNF, run:
[vpm048][WARNIN] 'dnf install python-dnf-plugins-extras-migrate && dnf-2 migrate'
[vpm048][WARNIN] 
[vpm048][DEBUG ] Last metadata expiration check performed 0:00:05 ago on Thu Jul  9 15:23:00 2015.
[vpm048][WARNIN] Package yum-plugin-priorities-1.1.31-505.fc22.noarch is already installed, skipping.
[vpm048][DEBUG ] Dependencies resolved.
[vpm048][DEBUG ] Nothing to do.
[vpm048][DEBUG ] Complete!
[vpm048][WARNIN] alter.d ceph.repo priorities to contain: priority=1
[vpm048][WARNIN] ensuring that /etc/yum.repos.d/ceph.repo contains a high priority
[vpm048][WARNIN] altered ceph.repo priorities to contain: priority=1
[vpm048][INFO  ] Running command: sudo yum -y -q install ceph ceph-radosgw
[vpm048][WARNIN] Yum command has been deprecated, redirecting to '/usr/bin/dnf -y -q install ceph ceph-radosgw'.
[vpm048][WARNIN] See 'man dnf' and 'man yum2dnf' for more information.
[vpm048][WARNIN] To transfer transaction metadata from yum to DNF, run:
[vpm048][WARNIN] 'dnf install python-dnf-plugins-extras-migrate && dnf-2 migrate'

Actions #1

Updated by Ken Dreyer almost 9 years ago

Does this stop ceph-deploy from running? "yum install foo" should still work, it'll just print some warnings.

Actions #2

Updated by Travis Rhoden over 8 years ago

  • Status changed from New to Fix Under Review
  • Assignee set to Travis Rhoden
  • Target version set to 1.5.26
Actions #3

Updated by Travis Rhoden over 8 years ago

One thing worth noting with the referenced PR is that because of the way that Fedora install is implemented, and because of having to use --dev master with F22, you will still see:

yum clean all
yum -y install yum-plugin-priorities

However, when it comes installing Ceph, you will now see:

dnf -y install ceph ceph-radosgw

Tis is because the dev mode for install git builders calls centos.mirror_install() for writing a .repo file pointing to gitbuilder, and I haven't modified CentOS to use the abstracted package manager yet.

Actions #4

Updated by Travis Rhoden over 8 years ago

  • Status changed from Fix Under Review to Resolved
Actions

Also available in: Atom PDF