Project

General

Profile

Actions

Bug #12168

closed

ceph-deploy disk --zap and --dmcrypt use store_true and default=None

Added by Travis Rhoden almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Target version:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

The code is using these values as boolean, so setting a default of None doesn't make sense.

The code works because doing "if zap:" works the same whether zap is None or False, but it really should be False in this case.

Actions #1

Updated by Travis Rhoden almost 9 years ago

  • Status changed from New to Fix Under Review
  • Target version set to 1.5.26
Actions #2

Updated by Travis Rhoden almost 9 years ago

  • Status changed from Fix Under Review to Resolved
Actions

Also available in: Atom PDF