Project

General

Profile

Actions

Bug #12147

closed

component install flags should not be mututally exclusive with version kind

Added by Travis Rhoden almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Crash signature (v1):
Crash signature (v2):

Description

Uncovered while adding unit tests for arparse, doing the following fails:

ceph-deploy install --mon --rgw [HOST]

with:

ceph-deploy install: error: argument --rgw: not allowed with argument --mon

Looking at the code, a bunch of args are added to the 'version' mutually exclusive arg group [1], and this appears to be my mistake. This mutex group should only cover --dev, --release, and --testing.

[1] https://github.com/ceph/ceph-deploy/blob/490a67691562f6713a66d15264ee23b4b54fc37c/ceph_deploy/install.py#L444

It looks like all of --rgw, --mon, --osd, --cli/--common, --all, --mds were put here by mistake. Those should all be independent.

--[no]-adjust-repos is also in that same mutex group, and it shouldn't be. That should be its own mutex group.

Actions #1

Updated by Travis Rhoden almost 9 years ago

  • Status changed from New to Fix Under Review
  • Target version set to 1.5.26
Actions #2

Updated by Travis Rhoden almost 9 years ago

  • Status changed from Fix Under Review to Resolved
Actions

Also available in: Atom PDF