Project

General

Profile

Bug #12069

ENOSPC hidden by cache not detected by callers of flatten

Added by Josh Durgin almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
High
Target version:
-
% Done:

0%

Source:
other
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Related to #12018, 'rbd flatten' doesn't detect the error flushing the cache, since it is implicit in closing the image. rbd_close() is void, so it cannot detect the error with the existing function.

We may need to add a rbd_close2() that has a return value.


Related issues

Related to rbd - Bug #12018: rbd and pool quota do not go well together Resolved 06/15/2015

Associated revisions

Revision 7ef4af5d (diff)
Added by Jason Dillaman almost 5 years ago

librbd: closing images now returns a result code

Added new librbd::Image::close method to allow checking the close result
when using the C++ librbd library. rbd_close is no longer hard-coded to
return 0.

Fixes: #12069
Signed-off-by: Jason Dillaman <>

History

#1 Updated by Josh Durgin almost 5 years ago

Once #12018 is fixed this will block, but we should be able to detect other errors that arise due to bugs (generally no errors should propagate to this layer).

#2 Updated by Josh Durgin almost 5 years ago

  • Priority changed from Normal to High

#3 Updated by Jason Dillaman almost 5 years ago

  • Status changed from New to In Progress
  • Assignee set to Jason Dillaman

#4 Updated by Jason Dillaman almost 5 years ago

rbd_close returns a status that is hard-coded to 0. Will add an optional close method to librbd::Image.

#5 Updated by Jason Dillaman almost 5 years ago

  • Status changed from In Progress to Fix Under Review

#6 Updated by Jason Dillaman over 4 years ago

  • Status changed from Fix Under Review to Resolved

Also available in: Atom PDF