Project

General

Profile

Bug #11974

Fix tool for #11442 does not correctly fix objects created via multipart uploads

Added by Benjamin Gilbert over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
-
Start date:
06/12/2015
Due date:
% Done:

0%

Source:
Community (user)
Tags:
Backport:
hammer
Regression:
No
Severity:
2 - major
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

radosgw-admin bucket check --check-head-obj-locator --fix claims to successfully fix objects that were created via multipart uploads, and subsequent --check-head-obj-locator invocations claim that the objects have, in fact, been fixed. However, those objects remain inaccessible by rgw 0.94.2, and remain accessible by rgw 0.94.1.


Related issues

Related to rgw - Bug #11984: Error with `radosgw-admin check --check-head-obj-locator --bucket=$bucket --fix` command Duplicate 06/12/2015
Related to rgw - Bug #12079: rgw: need conversion tool to handle fixes following #11974 Resolved 06/18/2015
Copied to rgw - Backport #12242: Fix tool for #11442 does not correctly fix objects created via multipart uploads Resolved 06/12/2015

Associated revisions

Revision d3bd27f4 (diff)
Added by Yehuda Sadeh over 4 years ago

rgw: fix reset_loc()

Fixes: #11974

Only need to set locator for underscore if namespace is empty

Signed-off-by: Yehuda Sadeh <>

Revision 557865c8 (diff)
Added by Yehuda Sadeh over 4 years ago

rgw: fix reset_loc()

Fixes: #11974

Only need to set locator for underscore if namespace is empty

Signed-off-by: Yehuda Sadeh <>
(cherry picked from commit d3bd27f4855df6bb207b656527138026af1a36a2)

History

#1 Updated by Sage Weil over 4 years ago

  • Status changed from New to Duplicate

#2 Updated by Benjamin Gilbert over 4 years ago

#11984 appears to be about a harmless warning produced by the tool. This bug is about the tool failing to fix the problem it was designed to fix.

#3 Updated by Yehuda Sadeh over 4 years ago

do you have any example of an object that was created with multipart upload that is not accessible? Does the object name start with an underscore, or is it every multipart object?

#4 Updated by Yehuda Sadeh over 4 years ago

  • Status changed from Duplicate to New

#5 Updated by Benjamin Gilbert over 4 years ago

In my tests, it seemed to affect all multipart objects starting with an underscore and created with 0.94.1. I've since reuploaded every affected object in our system, but I can downgrade an rgw and reproduce the problem again if that's helpful.

#6 Updated by Yehuda Sadeh over 4 years ago

  • Priority changed from Normal to Urgent

#7 Updated by Yehuda Sadeh over 4 years ago

  • Status changed from New to Pending Backport
  • Backport set to hammer

#8 Updated by Yehuda Sadeh over 4 years ago

merged to next, commit:0f6060c7c8e4576039a54080d17536e2169b6f63

#9 Updated by Yehuda Sadeh over 4 years ago

  • Assignee set to Loic Dachary

#10 Updated by Loic Dachary over 4 years ago

  • Assignee changed from Loic Dachary to Yehuda Sadeh

#12 Updated by Yehuda Sadeh over 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF