Project

General

Profile

Bug #1188

modprobe not found by mount.ceph

Added by Alexandre Oliva over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

  1. mount cephsrv:/ /mount/point
    sh: modprobe: command not found
    mount.ceph: modprobe failed, exit status 127

modprobe is in /sbin, but mount, being suid, restricts the PATH it passes down to mount.ceph.

Nevertheless, mount succeeds, presumably because either the mount binary or the mount system call issued by mount.ceph gets the module loaded.

I suppose delaying modprobe() after an initial mount attempt would silence the error without any negative impact. Redirecting the [error] output to the bit bucket would be a reasonable alternative; presumably dropping the modprobe altogether might do as well.

The above is on BLAG/x86_64, Fedora-based. On gNewSense/mipsel (Debian-based), modprobe runs successfully.

Associated revisions

Revision ad5ff230 (diff)
Added by Sage Weil over 8 years ago

mount.ceph: specify full path for /sbin/modprobe

Fixes: #1188
Signed-off-by: Sage Weil <>

History

#1 Updated by Sage Weil over 8 years ago

  • Target version set to v0.30

Does the mount.ceph is the modprobe branch work okay? It just specifies /sbin/modprobe.. which is hopefully always the case?

#2 Updated by Greg Farnum over 8 years ago

  • Status changed from New to Resolved
  • Assignee set to Sage Weil

Looks like this is done!

Also available in: Atom PDF