Project

General

Profile

Bug #11819

tests are being scheduled with unavailable packages?

Added by Greg Farnum about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
-
Category:
-
Target version:
-
Start date:
05/29/2015
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

We have an inordinate number of tests failing with messages like

Command failed on plana56 with status 8: 'wget http://gitbuilder.ceph.com/ceph-rpm-centos7-x86_64-basic/sha1/055c0c480e668581df421ebedc0c6e8f23e2aa0b/noarch/ceph-release-1-0.el7.noarch.rpm'

It seems to all be centos7, and my initial thought was that it just had the wrong URL for some reason (the gitbuilder is named centos7-amd64 while the URL refers to centos7-x86-64), but that turns out to be correct. Either the centos7 gitbuilder is just disappearing, or it's a bit slow and tests are being scheduled and executed before it's built the packages in question.

Examples suite runs where this is prevalent:
http://pulpito.ceph.com/teuthology-2015-05-27_21:00:01-rados-next-distro-basic-multi/
http://pulpito.ceph.com/teuthology-2015-05-27_23:02:01-rgw-next-distro-basic-multi/
http://pulpito.ceph.com/teuthology-2015-05-26_23:04:02-fs-next-testing-basic-multi/

History

#1 Updated by Greg Farnum about 4 years ago

  • Status changed from New to Resolved
  • Assignee deleted (Zack Cerza)

Apparently this has to do with centos7 changing the dist tag from el7 to el7.centos. It got fixed in the gitbuilder packaging scripts yesterday and shouldn't be a problem for builds that happened after that time.

Also available in: Atom PDF