Project

General

Profile

Bug #11807

workunits: stop rsyncing with /usr as the source material

Added by Greg Farnum about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
05/28/2015
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Component(FS):
Labels (FS):
Pull request ID:

Description

We've had various issues with /usr. The permissions on it are fiddly, its size can vary, and apparently some times the contents can change while running teuthology tests (?!!? #11781).

These tests are valuable; we've found many issues with directory contents because of them. Find something different that's appropriate to use in /usr's place.

Associated revisions

Revision 0de68ebb (diff)
Added by John Spray about 4 years ago

qa: fix multiple_rsync.sh to avoid using /usr/ directly

While we're at it, take only /usr/lib instead of all of /usr
to keep the overall file count more modest.

Fixes: #11807
Signed-off-by: John Spray <>

History

#1 Updated by Greg Farnum about 4 years ago

John suggests we can grab /usr/doc instead, maybe.

#2 Updated by John Spray about 4 years ago

  • Status changed from New to Need Review
  • Assignee set to John Spray

#3 Updated by Greg Farnum about 4 years ago

  • Status changed from Need Review to Resolved

3f4dfb80e32fba86e9076a2915197487bf899906

We can reopen if we decide this needs a backport.

Also available in: Atom PDF