Project

General

Profile

Bug #11574

utf8 and old gcc breakage on RHEL6.5

Added by Greg Farnum over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
05/08/2015
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
firefly,hammer
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:

Description

http://gitbuilder.sepia.ceph.com/gitbuilder-ceph-rpm-centos6-5-amd64-basic/#origin/master

I am more than a little confused about the errors being reported here. On master it starts with https://github.com/ceph/ceph/pull/4527, although http://gitbuilder.sepia.ceph.com/gitbuilder-ceph-rpm-centos6-5-amd64-basic/log.cgi?log=7f209b4bc8a55bfe9741121c3ade3f256bbe74f8 looks to just be about extra files being added to the package?

Meanwhile the next branch (http://gitbuilder.sepia.ceph.com/gitbuilder-ceph-rpm-centos6-5-amd64-basic/log.cgi?log=b65e93b125dd84dc142e24382404adf6b529473d) is failing on what actually looks like a json-spirit issue:

In file included from json_spirit/json_spirit_reader.cpp:7:
json_spirit/json_spirit_reader_template.h: In function 'String_type json_spirit::unicode_str_to_utf8(Iter_type&) [with String_type = std::string, Iter_type = __gnu_cxx::__normal_iterator, std::allocator > >]':
error: json_spirit/json_spirit_reader_template.h:82: using 'typename' outside of template


Related issues

Copied to Ceph - Backport #11715: utf8 and old gcc breakage on RHEL6.5 Resolved 05/08/2015
Copied to Ceph - Backport #11716: utf8 and old gcc breakage on RHEL6.5 Resolved 05/08/2015

Associated revisions

Revision 6b68b271 (diff)
Added by Kefu Chai over 4 years ago

json_sprit: fix the FTBFS on old gcc

Fixes: #11574
Signed-off-by: Kefu Chai <>

Revision b29cc4c1 (diff)
Added by Kefu Chai over 4 years ago

doc: Fix .gitignore for 'doc' directory

caused by: 156e55b7f95bb7f1d73e1131d94aca75fb339315

Fixes: #11574
Signed-off-by: Kefu Chai <>

Revision 424289dc (diff)
Added by Kefu Chai over 4 years ago

json_sprit: fix the FTBFS on old gcc

Fixes: #11574
Signed-off-by: Kefu Chai <>
(cherry picked from commit 6b68b27146852f057a3373cd04b08cd6917f3eea)

Revision 558d6391 (diff)
Added by Kefu Chai over 4 years ago

json_sprit: fix the FTBFS on old gcc

Fixes: #11574
Signed-off-by: Kefu Chai <>
(cherry picked from commit 6b68b27146852f057a3373cd04b08cd6917f3eea)

History

#1 Updated by Greg Farnum over 4 years ago

  • Assignee set to Kefu Chai

Giving this to you since you merged the PR. :)

#2 Updated by Kefu Chai over 4 years ago

  • Status changed from New to Need Review

#3 Updated by Greg Farnum over 4 years ago

  • Status changed from Need Review to Testing

#4 Updated by Kefu Chai over 4 years ago

  • Status changed from Testing to Resolved

all green now. consider it done.

#5 Updated by Kefu Chai over 4 years ago

  • Status changed from Resolved to Pending Backport
  • Backport set to firefly,hammer

#6 Updated by Nathan Cutler over 4 years ago

#7 Updated by Loic Dachary about 4 years ago

  • Subject changed from master and next broken on RHEL6.5 to utf8 and old gcc breakage on RHEL6.5

#8 Updated by Nathan Cutler about 4 years ago

  • Status changed from Pending Backport to Resolved

Also available in: Atom PDF