Project

General

Profile

Bug #11514

Typica nodes are not reliably clock synced

Added by Greg Farnum over 4 years ago. Updated almost 4 years ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
04/30/2015
Due date:
% Done:

0%

Source:
Q/A
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

http://pulpito-rdu.front.sepia.ceph.com/teuthology-2015-04-29_23:10:01-knfs-master-testing-basic-typica/7786/

^ that's one example, but we're seeing it a lot. The typica nodes aren't clock synced, or are jumping around, and it's causing tests to fail on log warnings (or occasionally on something a little less easy to skip, like timing-sensitive tests).

I know Dan looked at this some but I don't know if he came to any useful conclusions.


Related issues

Related to sepia - Bug #10675: failures related to clock skew Resolved 01/28/2015
Related to sepia - Bug #11782: lab clocks not reliably synced Can't reproduce 05/27/2015

History

#1 Updated by Greg Farnum over 4 years ago

  • Regression set to No

Here's one we're seeing pretty frequently: http://pulpito-rdu.front.sepia.ceph.com/teuthology-2015-05-05_23:14:01-samba-master-testing-basic-typica/11144/

2015-05-06T07:06:45.117 INFO:teuthology.orchestra.run.typica146.stdout:
2015-05-06T07:06:45.117 INFO:teuthology.orchestra.run.typica146.stdout:time: 2015-05-06 07:06:45.108907
2015-05-06T07:06:45.118 INFO:teuthology.orchestra.run.typica146.stdout:failure: defer_open [
2015-05-06T07:06:45.118 INFO:teuthology.orchestra.run.typica146.stdout:child 1 (pid 23373) failed: Timing incorrect 3.84 violation 1 sec == 1.00
2015-05-06T07:06:45.118 INFO:teuthology.orchestra.run.typica146.stdout:]
2015-05-06T07:06:45.119 INFO:teuthology.orchestra.run.typica146.stderr:WARNING!: child 0 (pid 23372) failed: Timing incorrect 3.36 violation 1 sec == 1.00

#2 Updated by David Galloway almost 4 years ago

  • Status changed from New to Won't Fix

Typica nodes have been relinquished to the CentOS Community so closing this issue as WONTFIX.

Also available in: Atom PDF