Project

General

Profile

Bug #11374

wip-subset: yaml assembly is putting tasks out-of-order

Added by Greg Farnum over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Core Tasks
Target version:
-
Start date:
04/13/2015
Due date:
% Done:

0%

Source:
Development
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:

Description

Here's one example; I am seeing many: http://qa-proxy.ceph.com/teuthology/gregf-2015-04-12_16:25:14-fs-greg-fs-testing-1-testing-basic-multi/844780/config.yaml

tasks:
- internal.check_packages: null
- internal.lock_machines:
  - 3
  - plana,mira,burnupi
- internal.save_config: null
- internal.check_lock: null
- internal.connect: null
- internal.push_inventory: null
- internal.serialize_remote_roles: null
- internal.check_conflict: null
- internal.check_ceph_data: null
- internal.vm_setup: null
- kernel: *id001
- internal.base: null
- internal.archive: null
- internal.coredump: null
- internal.sudo: null
- internal.syslog: null
- internal.timer: null
- chef: null
- clock.check: null
- mds_thrash: null
- install: null
- ceph: null
- ceph-fuse: null
- workunit:
    clients:
      all:
      - suites/fsstress.sh

Notice that the mds_thrash task is placed ahead of "install". Obviously things go terribly wrong.
As far as I can tell, nothing in the yaml fragments which this job is generated from have changed in more than a year, which leads me to believe that the teuthology code for assembling these must have changed. I'm not sure if it's consistently certain jobs being mis-ordered or if something else is going on.

History

#1 Updated by Andrew Schoen over 4 years ago

It doesn't look like this bit of teuthology code has changed anytime recently. It seems to construct the yaml fragments based on the alpha-order of the directory name. Maybe renaming ceph-thrash to just 'thrash' will get you the yaml you need?

Here are the fragments it's using for the linked run (in alpha-order).

['ceph-thrash/default.yaml', 'ceph/base.yaml', 'clusters/mds-1active-1standby.yaml', 'debug/mds_client.yaml', 'fs/btrfs.yaml', 'msgr-failures/none.yaml', 'overrides/whitelist_wrongly_marked_down.yaml', 'tasks/cfuse_workunit_suites_fsstress.yaml']

#2 Updated by Greg Farnum over 4 years ago

  • Subject changed from yaml assembly is putting tasks out-of-order to sip-subset: yaml assembly is putting tasks out-of-order
  • Assignee changed from Greg Farnum to Samuel Just

This turns out to be only a problem in wip-subset; you can see it by scheduling a dry run of the fs/thrash suite. It orders "ceph-thrash/default.yaml" ahead of "ceph/base.yaml".

That's kind of a blocker for merge...

#3 Updated by Greg Farnum over 4 years ago

  • Subject changed from sip-subset: yaml assembly is putting tasks out-of-order to wip-subset: yaml assembly is putting tasks out-of-order

#4 Updated by Sage Weil about 4 years ago

  • Status changed from New to Resolved
  • Regression set to No

Also available in: Atom PDF