Project

General

Profile

Bug #1124

Depend on new enough Boost

Added by Anonymous over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

Ensure that we depend on a new enough libboost to build successfully. Do this in

1. debian/control
2. autoconf

From the mailing list:

Message-ID: <4DE52AE3.9020900@sandia.gov>
Date: Tue, 31 May 2011 11:52:35 -0600
From: "Jim Schutt" <jaschut@sandia.gov>
Subject: Re: compile error for ceph-0.28.*.tar.gz

...
>> ./include/encoding.h:294: error: no matching function for call to
>> ?.ecode(PG::Log::Entry&, ceph::buffer::list::iterator&)?
>> ./include/encoding.h:42: note: candidates are: void decode(__u8&,
>> ceph::buffer::list::iterator&)
>> ... ...
>>
>> ./include/encoding.h:406: error: no matching function for call to
>> ?.ncode(const PG::Missing::item&, ceph::buffer::list&)?
>> ./include/encoding.h:42: note: candidates are: void encode(const
>> __u8&, ceph::bufferlist&)
>> ... ...
...
FWIW, I believe I saw such errors on RHEL 5 due to it having
boost v1.33.1, while Ceph needs v1.34 or newer to get statechart.

Associated revisions

Revision 1528d2c4 (diff)
Added by Sage Weil over 8 years ago

debian: depend on libboost-dev >= 1.34

for statechart. Partially fixes #1124.

Signed-off-by: Sage Weil <>

Revision 71543246 (diff)
Added by Sage Weil over 8 years ago

configure: check for boost statechart header

Partially fixes: #1124
Signed-off-by: Sage Weil <>

History

#1 Updated by Anonymous over 8 years ago

and

3. ceph.spec.in

#2 Updated by Sage Weil over 8 years ago

  • Target version set to v0.30
  • translation missing: en.field_story_points set to 1

#3 Updated by Sage Weil over 8 years ago

  • Status changed from New to Resolved

the version dependency in the .spec file is nontrivial (something about epochs?) and i'm too lazy to figure it out properly. the rest is done

Also available in: Atom PDF