Project

General

Profile

Bug #1118

Crash OSD after upgrdae from 0.28.1 to 0.28.2

Added by Fyodor Ustinov over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
OSD
Target version:
% Done:

0%

Source:
Tags:
Backport:
Regression:
No
Severity:
3 - minor
Reviewed:
Affected Versions:
ceph-qa-suite:
Pull request ID:
Crash signature:

Description

I know, "after" is not always "because". :)

I stop cosd, upgrade (by aptitude from yours repository) and start again.

The same effect on two different osd.

Log attached.

osdlog.tgz (3.28 KB) Fyodor Ustinov, 05/30/2011 01:27 PM

History

#1 Updated by Sage Weil over 8 years ago

  • Category set to OSD
  • Priority changed from Normal to High
  • Target version set to v0.30

#2 Updated by Josh Durgin over 8 years ago

  • Status changed from New to 4

This looks like the same problem as #1127. If you're not using ext3/4 or btrfs, it almost certainly is. Can you try the filestore_debugging branch?

#3 Updated by Josh Durgin over 8 years ago

  • Assignee set to Josh Durgin

#4 Updated by Fyodor Ustinov over 8 years ago

Yes, I use xfs.
Sorry, I cannot reproduce this error - I already reformat cluster.

#5 Updated by Sage Weil over 8 years ago

  • Status changed from 4 to Resolved

If it's xfs it sounds like that was it!

Also available in: Atom PDF